From f3c0d2f8606779c655b655e453b427d0714d6c2f Mon Sep 17 00:00:00 2001
From: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Date: Mon, 26 Jun 2023 14:58:21 +0200
Subject: [PATCH] gnu: Add texlive-luapackageloader.

* gnu/packages/tex.scm (texlive-luapackageloader): New variable.
---
 gnu/packages/tex.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)

diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 2c83ad62e4..c9f8fe2a35 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -16743,6 +16743,27 @@ it can be used to simply handle the parsing of optional @samp{key=value}
 arguments into proper Lua tables.")
     (license license:expat)))
 
+(define-public texlive-luapackageloader
+  (package
+    (name "texlive-luapackageloader")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/luatex/luapackageloader/"
+                   "tex/luatex/luapackageloader/")
+             (base32
+              "0cf2p4zhfvf7f10pbpp332chj46ajknqgb7a8i16v63ivvmgb8m3")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (propagated-inputs (list texlive-iftex))
+    (home-page "https://ctan.org/pkg/luapackageloader")
+    (synopsis "Allow LuaTeX to load external Lua packages")
+    (description
+     "This package allows LuaTeX to load packages from the default
+@code{package.path} and @code{package.cpath} locations.  This could be useful
+to load external Lua modules, including modules installed via LuaRocks.")
+    (license license:lppl1.3c)))
+
 (define-public texlive-babel-czech
   (package
     (name "texlive-babel-czech")