me
/
guix
Archived
1
0
Fork 0

gnu: vigra: Update to 1.11.1-0.9b514fa.

* gnu/packages/image.scm (vigra): Update to 1.11.1-0.9b514fa.
[source]: Use git-fetch. Remove obsolete patch.
* gnu/packages/patches/vigra-python-compat.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.
master
Leo Famulari 2021-08-08 15:53:12 -04:00
parent e012c29463
commit f4f4037fcd
No known key found for this signature in database
GPG Key ID: 2646FA30BACA7F08
3 changed files with 79 additions and 92 deletions

View File

@ -1795,7 +1795,6 @@ dist_patch_DATA = \
%D%/packages/patches/vboot-utils-fix-format-load-address.patch \
%D%/packages/patches/vboot-utils-fix-tests-show-contents.patch \
%D%/packages/patches/vboot-utils-skip-test-workbuf.patch \
%D%/packages/patches/vigra-python-compat.patch \
%D%/packages/patches/vinagre-newer-freerdp.patch \
%D%/packages/patches/vinagre-newer-rdp-parameters.patch \
%D%/packages/patches/virglrenderer-CVE-2017-6386.patch \

View File

@ -1175,18 +1175,25 @@ graphics image formats like PNG, BMP, JPEG, TIFF and others.")
(home-page "http://freeimage.sourceforge.net")))
(define-public vigra
(let ((commit "9b514fa00a136f5fd81bb57ee9f6293c333ffc1f")
(revision "0"))
(package
(name "vigra")
(version "1.11.1")
(version (git-version "1.11.1" revision commit))
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/ukoethe/vigra/releases/download/"
"Version-" (string-join (string-split version #\.) "-")
"/vigra-" version "-src.tar.gz"))
(patches (search-patches "vigra-python-compat.patch"))
;; The last release is 1.11.1, from 2017. It's becoming more and more
;; difficult to build this old release, and the upstream developers
;; suggest on their home page to build from the Git repo, saying "It is
;; generally safe to use the 'master' branch of the development snapshot,
;; as we avoid uploading untested or incompatible changes to this branch."
(method git-fetch)
(uri (git-reference
(url "https://github.com/ukoethe/vigra")
(commit commit)))
(file-name (git-file-name name version))
(sha256 (base32
"1bqs8vx5i1bzamvv563i24gx2xxdidqyxh9iaj46mbznhc84wmm5"))))
"1vzlypviala109imwxkp46lqhhxszf79ypfb8wxg6z7g02j7mm73"))))
(build-system cmake-build-system)
(inputs
`(("boost" ,boost)
@ -1246,8 +1253,7 @@ algorithms and data structures. It is particularly strong for
multi-dimensional image processing.")
(license license:expat)
(home-page "https://ukoethe.github.io/vigra/")
(properties '((max-silent-time . 7200))))) ;2 hours, to avoid timing out
(properties '((max-silent-time . 7200)))))) ;2 hours, to avoid timing out
(define-public vigra-c
(let* ((commit "66ff4fa5a7d4a77415caa676a45c2c6ea16562e7")

View File

@ -1,18 +0,0 @@
Fix build with Boost + Python 3.7.
Taken from upstream:
https://github.com/ukoethe/vigra/commit/a6fa62663c6a6b752ed0707e95f643e25867a0f9
diff --git a/vigranumpy/src/core/vigranumpycore.cxx b/vigranumpy/src/core/vigranumpycore.cxx
index ec38d3636..c81c6ae52 100644
--- a/vigranumpy/src/core/vigranumpycore.cxx
+++ b/vigranumpy/src/core/vigranumpycore.cxx
@@ -61,7 +61,7 @@ UInt32 pychecksum(python::str const & s)
return checksum(data, size);
#else
Py_ssize_t size = 0;
- char * data = PyUnicode_AsUTF8AndSize(s.ptr(), &size);
+ const char * data = PyUnicode_AsUTF8AndSize(s.ptr(), &size);
return checksum(data, size);
#endif
}