gnu: QtWebKit: Fix building with Python 3.9.
* gnu/packages/patches/qtwebkit-fix-building-with-python-3.9.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/qt.scm (qtwebkit)[source]: Use it. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>master
parent
0e6efd2c4a
commit
f5fda6eeab
gnu
packages
|
@ -1657,6 +1657,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/quassel-qt-514-compat.patch \
|
%D%/packages/patches/quassel-qt-514-compat.patch \
|
||||||
%D%/packages/patches/quickswitch-fix-dmenu-check.patch \
|
%D%/packages/patches/quickswitch-fix-dmenu-check.patch \
|
||||||
%D%/packages/patches/qtwebkit-pbutils-include.patch \
|
%D%/packages/patches/qtwebkit-pbutils-include.patch \
|
||||||
|
%D%/packages/patches/qtwebkit-fix-building-with-python-3.9.patch \
|
||||||
%D%/packages/patches/randomjungle-disable-static-build.patch \
|
%D%/packages/patches/randomjungle-disable-static-build.patch \
|
||||||
%D%/packages/patches/rapicorn-isnan.patch \
|
%D%/packages/patches/rapicorn-isnan.patch \
|
||||||
%D%/packages/patches/rapidjson-gcc-compat.patch \
|
%D%/packages/patches/rapidjson-gcc-compat.patch \
|
||||||
|
|
|
@ -0,0 +1,35 @@
|
||||||
|
Fix building with Python 3.9:
|
||||||
|
|
||||||
|
https://github.com/qtwebkit/qtwebkit/issues/993
|
||||||
|
|
||||||
|
Patch copied from upstream source repository:
|
||||||
|
|
||||||
|
https://github.com/qtwebkit/qtwebkit/commit/78360c01c796b6260bf828bc9c8a0ef73c5132fd
|
||||||
|
|
||||||
|
From 78360c01c796b6260bf828bc9c8a0ef73c5132fd Mon Sep 17 00:00:00 2001
|
||||||
|
From: Konstantin Tokarev <annulen@yandex.ru>
|
||||||
|
Date: Wed, 3 Jun 2020 15:01:42 +0300
|
||||||
|
Subject: [PATCH] Fix compilation with Python 3.9: avoid passing encoding to
|
||||||
|
json.load()
|
||||||
|
|
||||||
|
In Python 2.7 UTF-8 is assumed by default, while in Python 3 this argument
|
||||||
|
is not supported.
|
||||||
|
|
||||||
|
Change-Id: Ic459d60a6b20bc1838d8771bc36ac41614fe61a9
|
||||||
|
---
|
||||||
|
Source/JavaScriptCore/generate-bytecode-files | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/Source/JavaScriptCore/generate-bytecode-files b/Source/JavaScriptCore/generate-bytecode-files
|
||||||
|
index c5dab429c7b0f..af3431275ecf9 100644
|
||||||
|
--- a/Source/JavaScriptCore/generate-bytecode-files
|
||||||
|
+++ b/Source/JavaScriptCore/generate-bytecode-files
|
||||||
|
@@ -163,7 +163,7 @@ if __name__ == "__main__":
|
||||||
|
initBytecodesFile = openOrExit(initASMFileName, "w")
|
||||||
|
|
||||||
|
try:
|
||||||
|
- bytecodeSections = json.load(bytecodeFile, encoding = "utf-8")
|
||||||
|
+ bytecodeSections = json.load(bytecodeFile)
|
||||||
|
except:
|
||||||
|
print("Unexpected error parsing {0}: {1}".format(bytecodeJSONFile, sys.exc_info()))
|
||||||
|
|
|
@ -2624,7 +2624,8 @@ different kinds of sliders, and much more.")
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"1rm9sjkabxna67dl7myx9d9vpdyfxfdhrk9w7b94srkkjbd2d8cw"))
|
"1rm9sjkabxna67dl7myx9d9vpdyfxfdhrk9w7b94srkkjbd2d8cw"))
|
||||||
(patches (search-patches "qtwebkit-pbutils-include.patch"))))
|
(patches (search-patches "qtwebkit-pbutils-include.patch"
|
||||||
|
"qtwebkit-fix-building-with-python-3.9.patch"))))
|
||||||
(build-system cmake-build-system)
|
(build-system cmake-build-system)
|
||||||
(native-inputs
|
(native-inputs
|
||||||
`(("perl" ,perl)
|
`(("perl" ,perl)
|
||||||
|
|
Reference in New Issue