gnu: emacs-hyperbole: Update to 8.0.0.
* gnu/packages/emacs-xyz.scm (emacs-hyperbole): Update to 8.0.0. [arguments]<#:include>: Use %default-include. <#:phases>: Add build fix. * gnu/packages/patches/emacs-hyperbole-toggle-messaging.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Delete reference to removed file.master
parent
e31f3e9d1c
commit
f6b18b5372
|
@ -1033,7 +1033,6 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/emacs-json-reformat-fix-tests.patch \
|
%D%/packages/patches/emacs-json-reformat-fix-tests.patch \
|
||||||
%D%/packages/patches/emacs-helpful-fix-docstring-test.patch \
|
%D%/packages/patches/emacs-helpful-fix-docstring-test.patch \
|
||||||
%D%/packages/patches/emacs-highlight-stages-add-gexp.patch \
|
%D%/packages/patches/emacs-highlight-stages-add-gexp.patch \
|
||||||
%D%/packages/patches/emacs-hyperbole-toggle-messaging.patch \
|
|
||||||
%D%/packages/patches/emacs-libgit-use-system-libgit2.patch \
|
%D%/packages/patches/emacs-libgit-use-system-libgit2.patch \
|
||||||
%D%/packages/patches/emacs-lispy-fix-thread-last-test.patch \
|
%D%/packages/patches/emacs-lispy-fix-thread-last-test.patch \
|
||||||
%D%/packages/patches/emacs-source-date-epoch.patch \
|
%D%/packages/patches/emacs-source-date-epoch.patch \
|
||||||
|
|
|
@ -594,36 +594,36 @@ uploading PlatformIO projects.")
|
||||||
(define-public emacs-hyperbole
|
(define-public emacs-hyperbole
|
||||||
(package
|
(package
|
||||||
(name "emacs-hyperbole")
|
(name "emacs-hyperbole")
|
||||||
(version "7.1.3")
|
(version "8.0.0")
|
||||||
(source
|
(source
|
||||||
(origin
|
(origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append "https://elpa.gnu.org/packages/"
|
(uri (string-append "https://elpa.gnu.org/packages/"
|
||||||
"hyperbole-" version ".tar"))
|
"hyperbole-" version ".tar"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32 "0bizibn4qgxqp89fyik6p47s9hss1g932mg8k7pznn3kkhj5c8rh"))
|
(base32 "171x7jad62xd0n3xgs32dksyhn5abxj1kna0qgm65mm0v73hrv8d"))))
|
||||||
(patches
|
|
||||||
(search-patches "emacs-hyperbole-toggle-messaging.patch"))))
|
|
||||||
(build-system emacs-build-system)
|
(build-system emacs-build-system)
|
||||||
(arguments
|
(arguments
|
||||||
`(#:include '("DEMO"
|
`(#:include (cons* "DEMO"
|
||||||
"DEMO-ROLO.otl"
|
"DEMO-ROLO.otl"
|
||||||
"HY-ABOUT"
|
"HY-ABOUT"
|
||||||
"man/hkey-help.txt"
|
"man/hkey-help.txt"
|
||||||
"\\.el$"
|
"\\.kotl$"
|
||||||
"\\.info$"
|
%default-include)
|
||||||
"\\.kotl$")
|
|
||||||
#:phases
|
#:phases
|
||||||
(modify-phases %standard-phases
|
(modify-phases %standard-phases
|
||||||
;; Fix build issues about missing "domainname" and "hpmap:dir-user"
|
;; Fix build issues about missing "domainname" and "hpmap:dir-user"
|
||||||
;; parent dir.
|
;; parent dir, and missing require in "hgnus.el" (void-function:
|
||||||
|
;; var-append).
|
||||||
(add-after 'unpack 'fix-build
|
(add-after 'unpack 'fix-build
|
||||||
(lambda* (#:key inputs #:allow-other-keys)
|
(lambda* (#:key inputs #:allow-other-keys)
|
||||||
(substitute* "hypb.el"
|
(substitute* "hypb.el"
|
||||||
(("/bin/domainname")
|
(("/bin/domainname")
|
||||||
(search-input-file inputs "bin/dnsdomainname")))
|
(search-input-file inputs "bin/dnsdomainname")))
|
||||||
(substitute* "hyperbole.el"
|
(substitute* "hyperbole.el"
|
||||||
(("\\(hyperb:check-dir-user\\)") ""))))
|
(("\\(hyperb:check-dir-user\\)") ""))
|
||||||
|
(substitute* "hgnus.el"
|
||||||
|
(("hmail ") "hmail hvar "))))
|
||||||
(add-after 'install 'install-images
|
(add-after 'install 'install-images
|
||||||
(lambda* (#:key outputs #:allow-other-keys)
|
(lambda* (#:key outputs #:allow-other-keys)
|
||||||
(let ((out (assoc-ref outputs "out")))
|
(let ((out (assoc-ref outputs "out")))
|
||||||
|
|
|
@ -1,86 +0,0 @@
|
||||||
From 6d5c587ec719e3309077c7d637b03b13db65c047 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Joseph LaFreniere <joseph@lafreniere.xyz>
|
|
||||||
Date: Fri, 12 Jul 2019 12:43:46 -0500
|
|
||||||
Subject: [PATCH] Move definition of hyperbole-toggle-messaging to hsettings
|
|
||||||
|
|
||||||
---
|
|
||||||
hsettings.el | 25 +++++++++++++++++++++++++
|
|
||||||
hyperbole.el | 26 --------------------------
|
|
||||||
2 files changed, 25 insertions(+), 26 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/hsettings.el b/hsettings.el
|
|
||||||
index 6cdd1b8..9632067 100644
|
|
||||||
--- a/hsettings.el
|
|
||||||
+++ b/hsettings.el
|
|
||||||
@@ -163,6 +163,31 @@ package to display search results."
|
|
||||||
search-term)))
|
|
||||||
(user-error "(Hyperbole): Invalid web search service `%s'" service-name))))
|
|
||||||
|
|
||||||
+;;;###autoload
|
|
||||||
+(defun hyperbole-toggle-messaging (&optional arg)
|
|
||||||
+ "Toggle Hyperbole support for explicit buttons in mail and news buffers.
|
|
||||||
+Toggles the boolean variable `inhibit-hyperbole-messaging’ and either
|
|
||||||
+adds hooks (nil value) or removes them (t value).
|
|
||||||
+
|
|
||||||
+With optional prefix ARG > 0, enables support. If ARG <= 0,
|
|
||||||
+disables/inhibits support."
|
|
||||||
+ (interactive "P")
|
|
||||||
+ (setq inhibit-hyperbole-messaging (if (null arg)
|
|
||||||
+ (not inhibit-hyperbole-messaging)
|
|
||||||
+ (<= (prefix-numeric-value arg) 0)))
|
|
||||||
+ (if inhibit-hyperbole-messaging
|
|
||||||
+ (var:remove-all)
|
|
||||||
+ (var:append-all)
|
|
||||||
+ ;; Add any hooks that were skipped when inhibit-hyperbole-messaging
|
|
||||||
+ ;; was nil.
|
|
||||||
+ (cond ((boundp 'hyperbole-loading))
|
|
||||||
+ ((not after-init-time)
|
|
||||||
+ (add-hook 'after-init-hook (lambda () (load "hyperbole"))))
|
|
||||||
+ (t (load "hyperbole"))))
|
|
||||||
+ (if (called-interactively-p 'interactive)
|
|
||||||
+ (message "Hyperbole messaging button support is %s"
|
|
||||||
+ (if inhibit-hyperbole-messaging "disabled" "enabled"))))
|
|
||||||
+
|
|
||||||
(defcustom inhibit-hyperbole-messaging t
|
|
||||||
"*Determines whether Hyperbole supports explicit buttons in mail and news buffers.
|
|
||||||
The default of t means disable such support (work remains to
|
|
||||||
diff --git a/hyperbole.el b/hyperbole.el
|
|
||||||
index 4aa427d..872dbaf 100644
|
|
||||||
--- a/hyperbole.el
|
|
||||||
+++ b/hyperbole.el
|
|
||||||
@@ -121,32 +121,6 @@
|
|
||||||
t)))
|
|
||||||
(error "(Hyperbole): Startup failure: `hyperb:dir' must be manually added to `load-path' to fix.")))
|
|
||||||
|
|
||||||
-;; This must be defined before the defcustom `inhbit-hyperbole-messaging'.
|
|
||||||
-;;;###autoload
|
|
||||||
-(defun hyperbole-toggle-messaging (&optional arg)
|
|
||||||
- "Toggle Hyperbole support for explicit buttons in mail and news buffers.
|
|
||||||
-Toggles the boolean variable `inhibit-hyperbole-messaging’ and either
|
|
||||||
-adds hooks (nil value) or removes them (t value).
|
|
||||||
-
|
|
||||||
-With optional prefix ARG > 0, enables support. If ARG <= 0,
|
|
||||||
-disables/inhibits support."
|
|
||||||
- (interactive "P")
|
|
||||||
- (setq inhibit-hyperbole-messaging (if (null arg)
|
|
||||||
- (not inhibit-hyperbole-messaging)
|
|
||||||
- (<= (prefix-numeric-value arg) 0)))
|
|
||||||
- (if inhibit-hyperbole-messaging
|
|
||||||
- (var:remove-all)
|
|
||||||
- (var:append-all)
|
|
||||||
- ;; Add any hooks that were skipped when inhibit-hyperbole-messaging
|
|
||||||
- ;; was nil.
|
|
||||||
- (cond ((boundp 'hyperbole-loading))
|
|
||||||
- ((not after-init-time)
|
|
||||||
- (add-hook 'after-init-hook (lambda () (load "hyperbole"))))
|
|
||||||
- (t (load "hyperbole"))))
|
|
||||||
- (if (called-interactively-p 'interactive)
|
|
||||||
- (message "Hyperbole messaging button support is %s"
|
|
||||||
- (if inhibit-hyperbole-messaging "disabled" "enabled"))))
|
|
||||||
-
|
|
||||||
(defgroup hyperbole-koutliner nil
|
|
||||||
"Hyperbole multi-level autonumbered outliner customizations."
|
|
||||||
:group 'hyperbole)
|
|
||||||
--
|
|
||||||
2.22.0
|
|
||||||
|
|
Reference in New Issue