me
/
guix
Archived
1
0
Fork 0

gnu: emacs-helm-org-ql: Remove patch file.

* gnu/local.mk (emacs-helm-org-ql): Remove entry.
* gnu/packages/emacs-xyz.scm: Remove patch file.
* gnu/packages/patches/emacs-helm-org-ql.patch: Delete file.
master
Brian Leung 2019-10-11 02:41:21 +02:00
parent 8f1471149f
commit f7b3d9104e
No known key found for this signature in database
GPG Key ID: 3ADC75F013D678F9
3 changed files with 10 additions and 48 deletions

View File

@ -791,7 +791,6 @@ dist_patch_DATA = \
%D%/packages/patches/emacs-dired-toggle-sudo-emacs-26.patch \
%D%/packages/patches/emacs-exec-path.patch \
%D%/packages/patches/emacs-fix-scheme-indent-function.patch \
%D%/packages/patches/emacs-helm-org-ql.patch \
%D%/packages/patches/emacs-json-reformat-fix-tests.patch \
%D%/packages/patches/emacs-highlight-stages-add-gexp.patch \
%D%/packages/patches/emacs-scheme-complete-scheme-r5rs-info.patch \

View File

@ -11753,7 +11753,7 @@ according to a parsing expression grammar.")
(define-public emacs-org-ql
(let ((commit "949a06c3ab50482b749fd2d4350837a197660d96")
(revision "2"))
(revision "3"))
(package
(name "emacs-org-ql")
(version (git-version "0.3.1" revision commit))
@ -11765,9 +11765,6 @@ according to a parsing expression grammar.")
(sha256
(base32
"0apcg63xm0242mjgsgw0jrcda4p4iqj7fy3sgh0p7khi4hrs5ch0"))
(patches
(search-patches
"emacs-helm-org-ql.patch"))
(file-name (git-file-name name version))))
(build-system emacs-build-system)
(propagated-inputs
@ -11784,7 +11781,15 @@ according to a parsing expression grammar.")
(native-inputs
`(("emacs-buttercup" ,emacs-buttercup)))
(arguments
`(#:tests? #t
`(#:phases
(modify-phases %standard-phases
(add-after 'unpack 'require-helm
(lambda _
(substitute* "helm-org-ql.el"
(("^;;;; Requirements")
";;;; Requirements\n(require 'helm)\n(require 'helm-org)"))
#t)))
#:tests? #t
#:test-command '("buttercup" "-L" ".")))
(home-page "https://github.com/alphapapa/org-ql/")
(synopsis "Query language for Org buffers")

View File

@ -1,42 +0,0 @@
From 3918944856834ef4a7ed613243a1612424d2daba Mon Sep 17 00:00:00 2001
From: Brian Leung <leungbk@mailfence.com>
Date: Thu, 10 Oct 2019 06:54:33 +0200
Subject: [PATCH] Use require statements.
---
helm-org-ql.el | 19 ++-----------------
1 file changed, 2 insertions(+), 17 deletions(-)
diff --git a/helm-org-ql.el b/helm-org-ql.el
index 26beab9..113b7f2 100644
--- a/helm-org-ql.el
+++ b/helm-org-ql.el
@@ -35,23 +35,8 @@
(require 'org-ql)
(require 'org-ql-search)
-;; (require 'helm)
-;; (require 'helm-org)
-
-;;;; Compatibility
-
-;; Declare Helm functions since Helm may not be installed.
-(declare-function helm "ext:helm")
-(declare-function helm-run-after-exit "ext:helm")
-(declare-function helm-window "ext:helm-lib")
-(declare-function helm-buffer-get "ext:helm-lib")
-(declare-function helm-make-source "ext:helm-source")
-(declare-function helm-org-goto-marker "ext:helm-org")
-
-;; Silence byte-compiler about variables.
-(defvar helm-map)
-(defvar helm-pattern)
-(defvar helm-input-idle-delay)
+(require 'helm)
+(require 'helm-org)
;;;; Variables
--
2.23.0