gnu: network-manager: Build with Meson 0.60.
This is another way to address <https://github.com/mesonbuild/meson/issues/9492> as suggested by Nirbheek Chauhan and Paolo Bonzini. * gnu/packages/patches/network-manager-meson.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/gnome.scm (network-manager)[source]: Use it. [arguments]: Remove #:meson.master
parent
84c3aafb5a
commit
f862d7fb8d
|
@ -1492,6 +1492,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/ngircd-handle-zombies.patch \
|
%D%/packages/patches/ngircd-handle-zombies.patch \
|
||||||
%D%/packages/patches/ngless-unliftio.patch \
|
%D%/packages/patches/ngless-unliftio.patch \
|
||||||
%D%/packages/patches/network-manager-plugin-path.patch \
|
%D%/packages/patches/network-manager-plugin-path.patch \
|
||||||
|
%D%/packages/patches/network-manager-meson.patch \
|
||||||
%D%/packages/patches/nginx-socket-cloexec.patch \
|
%D%/packages/patches/nginx-socket-cloexec.patch \
|
||||||
%D%/packages/patches/nnpack-system-libraries.patch \
|
%D%/packages/patches/nnpack-system-libraries.patch \
|
||||||
%D%/packages/patches/nsis-env-passthru.patch \
|
%D%/packages/patches/nsis-env-passthru.patch \
|
||||||
|
|
|
@ -7899,7 +7899,8 @@ users.")
|
||||||
(uri (string-append "mirror://gnome/sources/NetworkManager/"
|
(uri (string-append "mirror://gnome/sources/NetworkManager/"
|
||||||
(version-major+minor version) "/"
|
(version-major+minor version) "/"
|
||||||
"NetworkManager-" version ".tar.xz"))
|
"NetworkManager-" version ".tar.xz"))
|
||||||
(patches (search-patches "network-manager-plugin-path.patch"))
|
(patches (search-patches "network-manager-plugin-path.patch"
|
||||||
|
"network-manager-meson.patch"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"0jzmz0zw64dgvdn2g7pppr7bkywpbxcbdb1viv6p7zh2lnh3dax8"))))
|
"0jzmz0zw64dgvdn2g7pppr7bkywpbxcbdb1viv6p7zh2lnh3dax8"))))
|
||||||
|
@ -7907,10 +7908,7 @@ users.")
|
||||||
(outputs '("out"
|
(outputs '("out"
|
||||||
"doc")) ; 8 MiB of gtk-doc HTML
|
"doc")) ; 8 MiB of gtk-doc HTML
|
||||||
(arguments
|
(arguments
|
||||||
;; Use meson-0.59, otherwise the custom rpaths are not registered
|
`(#:configure-flags
|
||||||
;; correctly (see: https://github.com/mesonbuild/meson/issues/9492).
|
|
||||||
`(#:meson ,meson-0.59
|
|
||||||
#:configure-flags
|
|
||||||
(let ((out (assoc-ref %outputs "out"))
|
(let ((out (assoc-ref %outputs "out"))
|
||||||
(dhclient (search-input-file %build-inputs "/sbin/dhclient")))
|
(dhclient (search-input-file %build-inputs "/sbin/dhclient")))
|
||||||
(list
|
(list
|
||||||
|
|
|
@ -0,0 +1,21 @@
|
||||||
|
Since libnm-wwan.so is not just a loadable module but also a shared library
|
||||||
|
that some plugin links against, build it as a shared library while avoiding
|
||||||
|
'-Wl,--no-undefined':
|
||||||
|
|
||||||
|
https://github.com/mesonbuild/meson/issues/9492#issuecomment-973117289
|
||||||
|
|
||||||
|
diff --git a/src/core/devices/wwan/meson.build b/src/core/devices/wwan/meson.build
|
||||||
|
index 37ef738..18ac54f 100644
|
||||||
|
--- a/src/core/devices/wwan/meson.build
|
||||||
|
+++ b/src/core/devices/wwan/meson.build
|
||||||
|
@@ -4,8 +4,9 @@ wwan_inc = include_directories('.')
|
||||||
|
|
||||||
|
linker_script = join_paths(meson.current_source_dir(), 'libnm-wwan.ver')
|
||||||
|
|
||||||
|
-libnm_wwan = shared_module(
|
||||||
|
+libnm_wwan = shared_library(
|
||||||
|
'nm-wwan',
|
||||||
|
+ override_options: ['b_lundef=false'],
|
||||||
|
sources: files(
|
||||||
|
'nm-service-providers.c',
|
||||||
|
'nm-modem-broadband.c',
|
Reference in New Issue