From f9a0cba91ac83f80b974eae6d0194b3415b2e409 Mon Sep 17 00:00:00 2001
From: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Date: Tue, 29 Aug 2023 15:55:34 +0200
Subject: [PATCH] gnu: Add texlive-mi-solns.

* gnu/packages/tex.scm (texlive-mi-solns): New variable.
---
 gnu/packages/tex.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)

diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 5919d0126d..b5fcc6f469 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -88826,6 +88826,27 @@ document.  In addition, @code{mftinc} provides routines for improved comment
 formatting and for typesetting font tables.")
     (license license:lppl)))
 
+(define-public texlive-mi-solns
+  (package
+    (name "texlive-mi-solns")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/mi-solns/"
+                   "source/latex/mi-solns/"
+                   "tex/latex/mi-solns/")
+             (base32
+              "1s8p7cibai4mc0pw9cqz87v3frq556wjh3kvvrxqs216s6wg9n53")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/mi-solns")
+    (synopsis "Extract solutions from exercises and quizzes")
+    (description
+     "This package is designed to mark a solution environment of an exercise or
+quiz and insert it into the same or a different document.  Solutions are ones
+created by either the @code{exerquiz} or @code{eqexam} package.")
+    (license license:lppl1.2+)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar