gnu: luajit: Update to commit 6c4826.
* gnu/packages/lua.scm (luajit)[source]: Use git-fetch, remove patch. * gnu/packages/patches/luajit-no_ldconfig.patch: Delete patch. * gnu/local.mk (dist_patch_DATA): Remove it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
parent
8d7c96284a
commit
fbdd0a4a14
|
@ -1506,7 +1506,6 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/lua-liblua-so.patch \
|
%D%/packages/patches/lua-liblua-so.patch \
|
||||||
%D%/packages/patches/lua-5.4-pkgconfig.patch \
|
%D%/packages/patches/lua-5.4-pkgconfig.patch \
|
||||||
%D%/packages/patches/lua-5.4-liblua-so.patch \
|
%D%/packages/patches/lua-5.4-liblua-so.patch \
|
||||||
%D%/packages/patches/luajit-no_ldconfig.patch \
|
|
||||||
%D%/packages/patches/luit-posix.patch \
|
%D%/packages/patches/luit-posix.patch \
|
||||||
%D%/packages/patches/lvm2-static-link.patch \
|
%D%/packages/patches/lvm2-static-link.patch \
|
||||||
%D%/packages/patches/mailutils-variable-lookup.patch \
|
%D%/packages/patches/mailutils-variable-lookup.patch \
|
||||||
|
|
|
@ -17,6 +17,7 @@
|
||||||
;;; Copyright © 2021 Greg Hogan <code@greghogan.com>
|
;;; Copyright © 2021 Greg Hogan <code@greghogan.com>
|
||||||
;;; Copyright © 2022 Brandon Lucas <br@ndon.dk>
|
;;; Copyright © 2022 Brandon Lucas <br@ndon.dk>
|
||||||
;;; Copyright © 2022 Luis Henrique Gomes Higino <luishenriquegh2701@gmail.com>
|
;;; Copyright © 2022 Luis Henrique Gomes Higino <luishenriquegh2701@gmail.com>
|
||||||
|
;;; Copyright © 2022 Leo Nikkilä <hello@lnikki.la>
|
||||||
;;;
|
;;;
|
||||||
;;; This file is part of GNU Guix.
|
;;; This file is part of GNU Guix.
|
||||||
;;;
|
;;;
|
||||||
|
@ -149,43 +150,47 @@ for configuration, scripting, and rapid prototyping.")
|
||||||
"lua51-pkgconfig.patch"))))))
|
"lua51-pkgconfig.patch"))))))
|
||||||
|
|
||||||
(define-public luajit
|
(define-public luajit
|
||||||
(package
|
(let ((branch "2.1.0-beta3")
|
||||||
(name "luajit")
|
(commit "6c4826f12c4d33b8b978004bc681eb1eef2be977"))
|
||||||
(version "2.1.0-beta3")
|
(package
|
||||||
(source (origin
|
(name "luajit")
|
||||||
(method url-fetch)
|
(version (git-version branch "0" commit))
|
||||||
(uri (string-append "http://luajit.org/download/LuaJIT-"
|
(source (origin
|
||||||
version ".tar.gz"))
|
(method git-fetch)
|
||||||
(sha256
|
(uri (git-reference
|
||||||
(base32 "1hyrhpkwjqsv54hnnx4cl8vk44h9d6c9w0fz1jfjz00w255y7lhs"))
|
(url "https://luajit.org/git/luajit.git")
|
||||||
(patches (search-patches "luajit-no_ldconfig.patch"))))
|
(commit commit)))
|
||||||
(build-system gnu-build-system)
|
(sha256
|
||||||
(arguments
|
(base32
|
||||||
`(#:tests? #f ; luajit is distributed without tests
|
"1a002yh8v1i1q9w09494q0b8vsbmw3amn9jgfs5qnz7ba54jij0q"))))
|
||||||
#:phases
|
(build-system gnu-build-system)
|
||||||
(modify-phases %standard-phases
|
(arguments
|
||||||
(delete 'configure) ; no configure script
|
`(#:tests? #f ; luajit is distributed without tests
|
||||||
(add-after 'install 'create-luajit-symlink
|
#:phases
|
||||||
(lambda* (#:key outputs #:allow-other-keys)
|
(modify-phases %standard-phases
|
||||||
(let* ((out (assoc-ref outputs "out"))
|
(delete 'configure) ; no configure script
|
||||||
(bin (string-append out "/bin")))
|
(add-after 'install 'create-luajit-symlink
|
||||||
(with-directory-excursion bin
|
(lambda* (#:key outputs #:allow-other-keys)
|
||||||
(symlink ,(string-append name "-" version)
|
(let* ((out (assoc-ref outputs "out"))
|
||||||
,name)
|
(bin (string-append out "/bin")))
|
||||||
#t)))))
|
(with-directory-excursion bin
|
||||||
#:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out")))))
|
(symlink ,(string-append name "-" branch)
|
||||||
(home-page "https://www.luajit.org/")
|
,name))))))
|
||||||
(synopsis "Just in time compiler for Lua programming language version 5.1")
|
#:make-flags (list (string-append "PREFIX="
|
||||||
;; On powerpc64le-linux, the build fails with an error: "No support for
|
(assoc-ref %outputs "out")))))
|
||||||
;; PowerPC 64 bit mode (yet)". See: https://issues.guix.gnu.org/49220
|
(home-page "https://www.luajit.org/")
|
||||||
(supported-systems (fold delete %supported-systems
|
(synopsis
|
||||||
(list "powerpc64le-linux" "riscv64-linux")))
|
"Just in time compiler for Lua programming language version 5.1")
|
||||||
(description
|
;; On powerpc64le-linux, the build fails with an error: "No support for
|
||||||
"LuaJIT is a Just-In-Time Compiler (JIT) for the Lua
|
;; PowerPC 64 bit mode (yet)". See: https://issues.guix.gnu.org/49220
|
||||||
|
(supported-systems (fold delete %supported-systems
|
||||||
|
(list "powerpc64le-linux" "riscv64-linux")))
|
||||||
|
(description
|
||||||
|
"LuaJIT is a Just-In-Time Compiler (JIT) for the Lua
|
||||||
programming language. Lua is a powerful, dynamic and light-weight programming
|
programming language. Lua is a powerful, dynamic and light-weight programming
|
||||||
language. It may be embedded or used as a general-purpose, stand-alone
|
language. It may be embedded or used as a general-purpose, stand-alone
|
||||||
language.")
|
language.")
|
||||||
(license license:x11)))
|
(license license:x11))))
|
||||||
|
|
||||||
(define-public luajit-lua52-openresty
|
(define-public luajit-lua52-openresty
|
||||||
(package
|
(package
|
||||||
|
|
|
@ -1,31 +0,0 @@
|
||||||
From 629200f48e18dc1a3a5229739748bad0e2a6a0a2 Mon Sep 17 00:00:00 2001
|
|
||||||
From: =?utf8?q?Tom=C3=A1=C5=A1=20=C4=8Cech?= <sleep_walker@suse.cz>
|
|
||||||
Date: Wed, 4 Feb 2015 11:37:16 +0100
|
|
||||||
Subject: [PATCH] Do not silently and prematurely end install when ldconfig is
|
|
||||||
missing
|
|
||||||
|
|
||||||
---
|
|
||||||
Makefile | 7 ++++---
|
|
||||||
1 file changed, 4 insertions(+), 3 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/Makefile b/Makefile
|
|
||||||
index 343ecb5..4667146 100644
|
|
||||||
--- a/Makefile
|
|
||||||
+++ b/Makefile
|
|
||||||
@@ -112,9 +112,10 @@ install: $(INSTALL_DEP)
|
|
||||||
$(RM) $(INSTALL_TSYM) $(INSTALL_DYN) $(INSTALL_SHORT1) $(INSTALL_SHORT2)
|
|
||||||
cd src && test -f $(FILE_SO) && \
|
|
||||||
$(INSTALL_X) $(FILE_SO) $(INSTALL_DYN) && \
|
|
||||||
- $(LDCONFIG) $(INSTALL_LIB) && \
|
|
||||||
- $(SYMLINK) $(INSTALL_SONAME) $(INSTALL_SHORT1) && \
|
|
||||||
- $(SYMLINK) $(INSTALL_SONAME) $(INSTALL_SHORT2) || :
|
|
||||||
+ ( $(LDCONFIG) $(INSTALL_LIB) ; \
|
|
||||||
+ $(SYMLINK) $(INSTALL_SONAME) $(INSTALL_SHORT1) && \
|
|
||||||
+ $(SYMLINK) $(INSTALL_SONAME) $(INSTALL_SHORT2) || : \
|
|
||||||
+ )
|
|
||||||
cd etc && $(INSTALL_F) $(FILE_MAN) $(INSTALL_MAN)
|
|
||||||
cd etc && $(SED_PC) $(FILE_PC) > $(FILE_PC).tmp && \
|
|
||||||
$(INSTALL_F) $(FILE_PC).tmp $(INSTALL_PC) && \
|
|
||||||
--
|
|
||||||
2.2.2
|
|
||||||
|
|
Reference in New Issue