me
/
guix
Archived
1
0
Fork 0

gnu: doxygen: Update to 1.9.5.

* gnu/packages/documentation.scm (doxygen): Update to 1.9.5.
[source](patches): Remove.
* gnu/packages/patches/doxygen-support-gcc-12.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
master
Marius Bakke 2022-09-05 14:19:20 +02:00
parent c37a31e9ab
commit fc64753bd3
No known key found for this signature in database
GPG Key ID: A2A06DF2A33A54FA
3 changed files with 2 additions and 20 deletions

View File

@ -1014,7 +1014,6 @@ dist_patch_DATA = \
%D%/packages/patches/doc++-include-directives.patch \
%D%/packages/patches/doc++-segfault-fix.patch \
%D%/packages/patches/dovecot-trees-support-dovecot-2.3.patch \
%D%/packages/patches/doxygen-support-gcc-12.patch \
%D%/packages/patches/dstat-fix-crash-when-specifying-delay.patch \
%D%/packages/patches/dstat-skip-devices-without-io.patch \
%D%/packages/patches/dvd+rw-tools-add-include.patch \

View File

@ -187,7 +187,7 @@ markup) can be customized and extended by the user.")
(define-public doxygen
(package
(name "doxygen")
(version "1.9.4")
(version "1.9.5")
(home-page "https://www.doxygen.nl/")
(source (origin
(method url-fetch)
@ -198,9 +198,7 @@ markup) can be customized and extended by the user.")
".src.tar.gz")))
(sha256
(base32
"0dqzgci82z950pzg6cpxvvqwybi2031flml3pj47hayhq3c9qpm1"))
;; Remove with next release.
(patches (search-patches "doxygen-support-gcc-12.patch"))))
"1v1f9cp5lyymg7xmw0ldnzi7ql8agbaqam1xdyljk0lrbnrm9d2m"))))
(build-system cmake-build-system)
(native-inputs
(list bison

View File

@ -1,15 +0,0 @@
Fix for https://github.com/doxygen/doxygen/issues/9312 made in unreleased upstream commit
https://github.com/doxygen/doxygen/commit/5198966c8d5fec89116d025c74934ac03ea511fa
diff --git a/src/cache.h b/src/cache.h
index 0ff3092ed5..e218eb27d2 100644
--- a/src/cache.h
+++ b/src/cache.h
@@ -19,6 +19,7 @@
#include <list>
#include <unordered_map>
#include <mutex>
+#include <utility>
#include <ctype.h>
/*! Fixed size cache for value type V using keys of type K.