me
/
guix
Archived
1
0
Fork 0

gnu: python-tinycss2: Update to 1.1.0.

* gnu/packages/patches/python-tinycss2-flake8-compat.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): De-register it.
* gnu/packages/python-web.scm (python-tinycss2): Update to 1.1.0.
[source]: Remove patch.
[arguments]: Remove field, disabling tests.
[native-inputs]: Remove field.
master
Maxim Cournoyer 2020-11-28 03:06:24 -05:00
parent e1f86df4e4
commit fc72594c28
No known key found for this signature in database
GPG Key ID: 1260E46482E63562
3 changed files with 6 additions and 48 deletions

View File

@ -1537,7 +1537,6 @@ dist_patch_DATA = \
%D%/packages/patches/python-robotframework-source-date-epoch.patch \
%D%/packages/patches/python-shouldbe-0.1.2-cpy3.8.patch \
%D%/packages/patches/python2-subprocess32-disable-input-test.patch \
%D%/packages/patches/python-tinycss2-flake8-compat.patch \
%D%/packages/patches/python-unittest2-python3-compat.patch \
%D%/packages/patches/python-unittest2-remove-argparse.patch \
%D%/packages/patches/python-waitress-fix-tests.patch \

View File

@ -1,36 +0,0 @@
Fix test failure that occurs with recent versions of Flake8.
Taken from upstream:
https://github.com/Kozea/tinycss2/commit/6556604fb98c2153412384d6f0f705db2da1aa60
diff --git a/tinycss2/css-parsing-tests/make_color3_hsl.py b/tinycss2/css-parsing-tests/make_color3_hsl.py
index d1fd3a6..56fda0c 100644
--- a/tinycss2/css-parsing-tests/make_color3_hsl.py
+++ b/tinycss2/css-parsing-tests/make_color3_hsl.py
@@ -8,16 +8,17 @@ def trim(s):
print('[')
print(',\n'.join(
'"hsl%s(%s, %s%%, %s%%%s)", [%s, %s, %s, %s]' % (
- ('a' if a is not None else '', h,
- trim(str(s / 10.)), trim(str(l / 10.)),
- ', %s' % a if a is not None else '') +
+ ('a' if alpha is not None else '', hue,
+ trim(str(saturation / 10.)), trim(str(light / 10.)),
+ ', %s' % alpha if alpha is not None else '') +
tuple(trim(str(round(v, 10)))
- for v in colorsys.hls_to_rgb(h / 360., l / 1000., s / 1000.)) +
- (a if a is not None else 1,)
+ for v in colorsys.hls_to_rgb(
+ hue / 360., light / 1000., saturation / 1000.)) +
+ (alpha if alpha is not None else 1,)
)
- for a in [None, 1, .2, 0]
- for l in range(0, 1001, 125)
- for s in range(0, 1001, 125)
- for h in range(0, 360, 30)
+ for alpha in [None, 1, .2, 0]
+ for light in range(0, 1001, 125)
+ for saturation in range(0, 1001, 125)
+ for hue in range(0, 360, 30)
))
print(']')

View File

@ -4433,26 +4433,21 @@ library to create slugs from unicode strings while keeping it DRY.")
(define-public python-tinycss2
(package
(name "python-tinycss2")
(version "1.0.2")
(version "1.1.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "tinycss2" version))
(patches (search-patches "python-tinycss2-flake8-compat.patch"))
(sha256
(base32 "1kw84y09lggji4krkc58jyhsfj31w8npwhznr7lf19d0zbix09v4"))))
(base32 "12p16k8x8ig51gpfcwz3k3kxpxrwwkn41a1avdgvh3nn8hqarp7v"))))
(build-system python-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
(replace 'check
(lambda _ (invoke "pytest"))))))
;; Test data is missing from the PyPI archive, and the build system is
;; based on Flit, which wants an unmaintained and unpackaged
;; python-pytoml dependency.
`(#:tests? #f))
(propagated-inputs
`(("python-webencodings" ,python-webencodings)))
(native-inputs
`(("python-pytest-flake8" ,python-pytest-flake8)
("python-pytest-isort" ,python-pytest-isort)
("python-pytest-runner" ,python-pytest-runner)))
(home-page "https://tinycss2.readthedocs.io/")
(synopsis "Low-level CSS parser for Python")
(description "@code{tinycss2} can parse strings, return Python objects