gnu: python-pyqt: Update to 5.14.2.
* gnu/packages/qt.scm (python-pyqt): Update to 5.14.2. [source](uri): Add PyPI mirror. [source](patches): Remove obsolete. * gnu/packages/patches/pyqt-unbundled-qt.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly.master
parent
8cbb32da7d
commit
fd702f8e95
|
@ -1395,7 +1395,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/pygpgme-disable-problematic-tests.patch \
|
||||
%D%/packages/patches/pyqt-configure.patch \
|
||||
%D%/packages/patches/pyqt-public-sip.patch \
|
||||
%D%/packages/patches/pyqt-unbundled-qt.patch \
|
||||
%D%/packages/patches/python-2-deterministic-build-info.patch \
|
||||
%D%/packages/patches/python-2.7-adjust-tests.patch \
|
||||
%D%/packages/patches/python-2.7-search-paths.patch \
|
||||
|
|
|
@ -1,19 +0,0 @@
|
|||
Remove test for bundled Qt which breaks dependent applications. This has
|
||||
been fixed in 5.13.
|
||||
|
||||
Taken from Arch Linux:
|
||||
https://git.archlinux.org/svntogit/packages.git/tree/trunk/python2-pyqt5-crash-fix.patch?h=packages/pyqt5&id=3e56e11d1fd7b1eac8242ce64c58db2bd9acba20
|
||||
|
||||
diff -ur PyQt5_gpl-5.12.3/qpy/QtCore/qpycore_post_init.cpp.in PyQt5_gpl-5.12.3b/qpy/QtCore/qpycore_post_init.cpp.in
|
||||
--- PyQt5_gpl-5.12.3/qpy/QtCore/qpycore_post_init.cpp.in 2019-06-25 14:41:02.000000000 +0200
|
||||
+++ PyQt5_gpl-5.12.3b/qpy/QtCore/qpycore_post_init.cpp.in 2019-07-01 17:06:34.882644535 +0200
|
||||
@@ -151,8 +151,4 @@
|
||||
// initialised first (at least for Windows) and this is the only way to
|
||||
// guarantee things are done in the right order.
|
||||
PyQtSlotProxy::mutex = new QMutex(QMutex::Recursive);
|
||||
-
|
||||
- // Load the embedded qt.conf file if there is a bundled copy of Qt.
|
||||
- if (!qpycore_qt_conf())
|
||||
- Py_FatalError("PyQt5.QtCore: Unable to embed qt.conf");
|
||||
}
|
||||
|
|
@ -1945,18 +1945,21 @@ module provides support functions to the automatically generated code.")
|
|||
(define-public python-pyqt
|
||||
(package
|
||||
(name "python-pyqt")
|
||||
(version "5.12.3")
|
||||
(version "5.14.2")
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "https://www.riverbankcomputing.com/static/"
|
||||
"Downloads/PyQt5/" version "/PyQt5_gpl-"
|
||||
version ".tar.gz"))
|
||||
;; PyPI is the canonical distribution point of PyQt. Older
|
||||
;; releases are available from the web site.
|
||||
(uri (list (pypi-uri "PyQt5" version)
|
||||
(string-append "https://www.riverbankcomputing.com/static/"
|
||||
"Downloads/PyQt5/" version "/PyQt5-"
|
||||
version ".tar.gz")))
|
||||
(file-name (string-append "PyQt5-"version ".tar.gz"))
|
||||
(sha256
|
||||
(base32
|
||||
"041155bdzp57jy747p5d59740c55yy3241cy1x2lgcdsvqvzmc0d"))
|
||||
"1c4y4qi1l540gd125ikj0al00k5pg65kmqaixcfbzslrsrphq8xx"))
|
||||
(patches (search-patches "pyqt-configure.patch"
|
||||
"pyqt-unbundled-qt.patch"
|
||||
"pyqt-public-sip.patch"))))
|
||||
(build-system gnu-build-system)
|
||||
(native-inputs
|
||||
|
|
Reference in New Issue