gnu: u-boot: Update to 2020.10.
* gnu/packages/bootloaders (u-boot): Update to 2020.10. * gnu/packages/patches/u-boot-riscv64-fix-extlinux.patch: Refresh patch.master
parent
2a4f3c1711
commit
fe6067fc24
|
@ -446,7 +446,7 @@ tree binary files. These are board description files used by Linux and BSD.")
|
|||
(define u-boot
|
||||
(package
|
||||
(name "u-boot")
|
||||
(version "2020.07")
|
||||
(version "2020.10")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append
|
||||
|
@ -454,7 +454,7 @@ tree binary files. These are board description files used by Linux and BSD.")
|
|||
"u-boot-" version ".tar.bz2"))
|
||||
(sha256
|
||||
(base32
|
||||
"0sjzy262x93aaqd6z24ziaq19xjjjk5f577ivf768vmvwsgbzxf1"))))
|
||||
"08m6f1bh4pdcqbxf983qdb66ccd5vak5cbzc114yf3jwq2yinj0d"))))
|
||||
(native-inputs
|
||||
`(("bc" ,bc)
|
||||
("bison" ,bison)
|
||||
|
|
|
@ -32,9 +32,9 @@ Index: u-boot/configs/sifive_fu540_defconfig
|
|||
===================================================================
|
||||
--- u-boot.orig/configs/sifive_fu540_defconfig
|
||||
+++ u-boot/configs/sifive_fu540_defconfig
|
||||
@@ -12,3 +12,5 @@ CONFIG_DISPLAY_BOARDINFO=y
|
||||
CONFIG_DEFAULT_DEVICE_TREE="hifive-unleashed-a00"
|
||||
CONFIG_SYS_RELOC_GD_ENV_ADDR=y
|
||||
@@ -27,3 +27,5 @@ CONFIG_SPL_DM_SEQ_ALIAS=y
|
||||
CONFIG_SPL_CLK=y
|
||||
CONFIG_DM_MTD=y
|
||||
CONFIG_DM_RESET=y
|
||||
+CONFIG_USE_PREBOOT=y
|
||||
+CONFIG_PREBOOT="setenv fdt_addr ${fdtcontroladdr}; fdt addr ${fdtcontroladdr};"
|
||||
|
|
Reference in New Issue