From fe7023a744b9c6753a250475ed1c908e25413f2a Mon Sep 17 00:00:00 2001
From: Efraim Flashner <efraim@flashner.co.il>
Date: Wed, 7 Aug 2019 19:16:15 +0300
Subject: [PATCH] gnu: i3blocks: Remove extra build phase.

* gnu/packages/wm.scm (i3blocks)[arguments]: Remove unneeded 'autogen
phase.
---
 gnu/packages/wm.scm | 2 --
 1 file changed, 2 deletions(-)

diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index c56cf406ee..160c267882 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -290,8 +290,6 @@ Despite the name it should work with any X11 window manager.")
       (arguments
        `(#:make-flags (list "CC=gcc" (string-append "PREFIX=" %output))
          #:phases (modify-phases %standard-phases
-                    (add-after 'unpack 'autogen
-                      (lambda _ (invoke "sh" "autogen.sh")))
                     (add-after 'install 'install-doc
                       (lambda* (#:key outputs #:allow-other-keys)
                         (let* ((out (assoc-ref outputs "out"))