me
/
guix
Archived
1
0
Fork 0

gnu: timescaledb: Update to 2.8.1.

* gnu/packages/patches/timescaledb-flaky-test.patch: Remove.
* gnu/local.mk (dist_patch_DATA): Remove it.
* gnu/packages/databases.scm (timescaledb): Update to 2.8.1.
[source]: Remove patch.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
master
jgart 2022-11-10 20:06:24 -06:00 committed by Ludovic Courtès
parent cdfc1f41c6
commit ff00cdcd92
No known key found for this signature in database
GPG Key ID: 090B11993D9AEBB5
3 changed files with 4 additions and 112 deletions

View File

@ -55,6 +55,7 @@
# Copyright © 2022 Hilton Chain <hako@ultrarare.space>
# Copyright © 2022 Alex Griffin <a@ajgrf.com>
# Copyright © 2022 ( <paren@disroot.org>
# Copyright © 2022 jgart <jgart@dismail.de>
#
# This file is part of GNU Guix.
#
@ -1895,7 +1896,6 @@ dist_patch_DATA = \
%D%/packages/patches/texlive-hyph-utf8-no-byebug.patch \
%D%/packages/patches/thefuck-test-environ.patch \
%D%/packages/patches/tidy-CVE-2015-5522+5523.patch \
%D%/packages/patches/timescaledb-flaky-test.patch \
%D%/packages/patches/tinyxml-use-stl.patch \
%D%/packages/patches/tipp10-disable-downloader.patch \
%D%/packages/patches/tipp10-fix-compiling.patch \

View File

@ -53,12 +53,12 @@
;;; Copyright © 2021 Simon Streit <simon@netpanic.org>
;;; Copyright © 2021 Alexandre Hannud Abdo <abdo@member.fsf.org>
;;; Copyright © 2021 Simon Tournier <zimon.toutoune@gmail.com>
;;; Copyright © 2021 jgart <jgart@dismail.de>
;;; Copyright © 2021 Foo Chuan Wei <chuanwei.foo@hotmail.com>
;;; Copyright © 2022 Zhu Zihao <all_but_last@163.com>
;;; Copyright © 2021 Brice Waegeneire <brice@waegenei.re>
;;; Copyright © 2022 muradm <mail@muradm.net>
;;; Copyright © 2022 Thomas Albers Raviola <thomas@thomaslabs.org>
;;; Copyright © 2021, 2022 jgart <jgart@dismail.de>
;;;
;;; This file is part of GNU Guix.
;;;
@ -1333,7 +1333,7 @@ pictures, sounds, or video.")
(define-public timescaledb
(package
(name "timescaledb")
(version "2.7.0")
(version "2.8.1")
(source (origin
(method git-fetch)
(uri (git-reference
@ -1342,8 +1342,7 @@ pictures, sounds, or video.")
(file-name (git-file-name name version))
(sha256
(base32
"18wszj8ia5rs4y4zkyfb0f5z4y1g7ac3jym748nbkbszhxmq7nc7"))
(patches (search-patches "timescaledb-flaky-test.patch"))
"1gbadna0ilmqad7sbrixm12wd71h43njhsbp1kh5lispb6drdb6r"))
(modules '((guix build utils)))
(snippet
;; Remove files carrying the proprietary TIMESCALE license.

View File

@ -1,107 +0,0 @@
Use fixed dates in test for consistent results.
Taken from upstream:
https://github.com/timescale/timescaledb/commit/1d0670e703862b284c241ab797404f851b25b5df
diff --git a/test/expected/copy-12.out b/test/expected/copy-12.out
index 5cb28a45a2..37abf6f6ff 100644
--- a/test/expected/copy-12.out
+++ b/test/expected/copy-12.out
@@ -324,13 +324,12 @@ INSERT INTO hyper_copy_large
SELECT time,
random() AS value
FROM
-generate_series(now() - INTERVAL '1 months', now() - INTERVAL '1 day',
- INTERVAL '1 hour') AS g1(time)
+generate_series('2022-01-01', '2022-01-31', INTERVAL '1 hour') AS g1(time)
ORDER BY time;
SELECT COUNT(*) FROM hyper_copy_large;
count
-------
- 697
+ 721
(1 row)
-- Migrate data to chunks by using copy
@@ -345,7 +344,7 @@ NOTICE: migrating data to chunks
SELECT COUNT(*) FROM hyper_copy_large;
count
-------
- 697
+ 721
(1 row)
----------------------------------------------------------------
diff --git a/test/expected/copy-13.out b/test/expected/copy-13.out
index 02bf913eff..89e16fe8e2 100644
--- a/test/expected/copy-13.out
+++ b/test/expected/copy-13.out
@@ -324,13 +324,12 @@ INSERT INTO hyper_copy_large
SELECT time,
random() AS value
FROM
-generate_series(now() - INTERVAL '1 months', now() - INTERVAL '1 day',
- INTERVAL '1 hour') AS g1(time)
+generate_series('2022-01-01', '2022-01-31', INTERVAL '1 hour') AS g1(time)
ORDER BY time;
SELECT COUNT(*) FROM hyper_copy_large;
count
-------
- 697
+ 721
(1 row)
-- Migrate data to chunks by using copy
@@ -345,7 +344,7 @@ NOTICE: migrating data to chunks
SELECT COUNT(*) FROM hyper_copy_large;
count
-------
- 697
+ 721
(1 row)
----------------------------------------------------------------
diff --git a/test/expected/copy-14.out b/test/expected/copy-14.out
index 02bf913eff..89e16fe8e2 100644
--- a/test/expected/copy-14.out
+++ b/test/expected/copy-14.out
@@ -324,13 +324,12 @@ INSERT INTO hyper_copy_large
SELECT time,
random() AS value
FROM
-generate_series(now() - INTERVAL '1 months', now() - INTERVAL '1 day',
- INTERVAL '1 hour') AS g1(time)
+generate_series('2022-01-01', '2022-01-31', INTERVAL '1 hour') AS g1(time)
ORDER BY time;
SELECT COUNT(*) FROM hyper_copy_large;
count
-------
- 697
+ 721
(1 row)
-- Migrate data to chunks by using copy
@@ -345,7 +344,7 @@ NOTICE: migrating data to chunks
SELECT COUNT(*) FROM hyper_copy_large;
count
-------
- 697
+ 721
(1 row)
----------------------------------------------------------------
diff --git a/test/sql/copy.sql.in b/test/sql/copy.sql.in
index 91402c2ab8..bba4265064 100644
--- a/test/sql/copy.sql.in
+++ b/test/sql/copy.sql.in
@@ -276,8 +276,7 @@ INSERT INTO hyper_copy_large
SELECT time,
random() AS value
FROM
-generate_series(now() - INTERVAL '1 months', now() - INTERVAL '1 day',
- INTERVAL '1 hour') AS g1(time)
+generate_series('2022-01-01', '2022-01-31', INTERVAL '1 hour') AS g1(time)
ORDER BY time;
SELECT COUNT(*) FROM hyper_copy_large;