From ff3f52335255b05c6de3351b298137150534ca99 Mon Sep 17 00:00:00 2001
From: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Date: Wed, 12 Jul 2023 21:52:22 +0200
Subject: [PATCH] gnu: Add texlive-bardiag.

* gnu/packages/tex.scm (texlive-bardiag): New variable.
---
 gnu/packages/tex.scm | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)

diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 574776bb0d..d481417baf 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -16135,6 +16135,25 @@ of a picture between running text and margins and for keeping the running text
 away.")
     (license license:lppl)))
 
+(define-public texlive-bardiag
+  (package
+    (name "texlive-bardiag")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/bardiag/" "tex/latex/bardiag/")
+             (base32
+              "1iy0cr24ki93jlnmzr1fgqa7jqg0zhxds422cz322zwr19936zz9")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/bardiag")
+    (synopsis "LaTeX package for drawing bar diagrams")
+    (description
+     "The main purpose of the package is to make the drawing of bar diagrams
+possible and easy in LaTeX.  The BarDiag package is inspired by and based on
+PSTricks.")
+    (license license:lppl)))
+
 (define-public texlive-barracuda
   (package
     (name "texlive-barracuda")