me
/
guix
Archived
1
0
Fork 0
This repository has been archived on 2024-08-07. You can view files and clone it, but cannot push or open issues/pull-requests.
guix/gnu/packages/patches/bloomberg-bde-cmake-module-...

15 lines
495 B
Diff

This package requires CMAKE_MODULE_PATH be set by the calling process. This
patch uses the CMAKE_PREFIX_PATH passed from Guix as the search path for
locating the bloomberg-bde-tools CMake modules.
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -14,6 +14,7 @@ else()
if (NOT CMAKE_MODULE_PATH)
message(FATAL "Please specify path to BDE cmake modules.")
endif()
+ string(REPLACE ":" "cmake/;" CMAKE_MODULE_PATH "$ENV{CMAKE_PREFIX_PATH}cmake/")
include(bde_workspace)