me
/
guix
Archived
1
0
Fork 0
This repository has been archived on 2024-08-07. You can view files and clone it, but cannot push or open issues/pull-requests.
guix/gnu/packages/patches/gobject-introspection-cc-1....

16 lines
537 B
Diff

Use gcc as the default C compiler if CC is not set.
diff --git a/giscanner/__init__.py b/giscanner/__init__.py
index 7c2f365a..607fe341 100644
--- a/giscanner/__init__.py
+++ b/giscanner/__init__.py
@@ -21,6 +21,8 @@ import os
builddir = os.environ.get('UNINSTALLED_INTROSPECTION_BUILDDIR')
if builddir is not None:
__path__.append(os.path.join(builddir, 'giscanner')) # type: ignore # mypy issue #1422
+if not 'CC' in os.environ:
+ os.environ['CC'] = 'gcc'
try:
from ._version import __version__
except ImportError: