me
/
guix
Archived
1
0
Fork 0
This repository has been archived on 2024-08-07. You can view files and clone it, but cannot push or open issues/pull-requests.
guix/gnu/packages/patches/python-3-deterministic-buil...

18 lines
444 B
Diff

Always provide the same date and time in 'Py_GetBuildInfo'.
This is the information shown at the REPL and in 'sys.version'.
We cannot pass it in CPPFLAGS due to whitespace in the DATE string.
--- a/Modules/getbuildinfo.c
+++ b/Modules/getbuildinfo.c
@@ -4,6 +4,10 @@
#include <stdio.h>
#endif
+/* Deterministic date and time. */
+#define DATE "Jan 1 1970"
+#define TIME "00:00:01"
+
#ifndef DATE
#ifdef __DATE__
#define DATE __DATE__