me
/
guix
Archived
1
0
Fork 0
This repository has been archived on 2024-08-07. You can view files and clone it, but cannot push or open issues/pull-requests.
guix/gnu/packages/patches/qtdeclarative-disable-qmlca...

32 lines
1.1 KiB
Diff

Retrieved from
https://raw.githubusercontent.com/NixOS/nixpkgs/master/pkgs/development/libraries/qt-6/patches/qtdeclarative-default-disable-qmlcache.patch
From 2d561e0a80f2d123a7348187975ee845f9dcd9e0 Mon Sep 17 00:00:00 2001
From: Nick Cao <nickcao@nichi.co>
Date: Tue, 10 Oct 2023 11:12:27 -0400
Subject: [PATCH] qtdeclarative: disable qml disk cache
---
src/qml/jsruntime/qv4engine.cpp | 6 +-----
1 file changed, 1 insertion(+), 5 deletions(-)
diff --git a/src/qml/jsruntime/qv4engine.cpp b/src/qml/jsruntime/qv4engine.cpp
index d1b4c4fff6..50f8a07420 100644
--- a/src/qml/jsruntime/qv4engine.cpp
+++ b/src/qml/jsruntime/qv4engine.cpp
@@ -2232,11 +2232,7 @@ ExecutionEngine::DiskCacheOptions ExecutionEngine::diskCacheOptions() const
{
if (forceDiskCache())
return DiskCache::Enabled;
- if (disableDiskCache() || debugger())
- return DiskCache::Disabled;
- static const DiskCacheOptions options = qmlGetConfigOption<
- DiskCacheOptions, transFormDiskCache>("QML_DISK_CACHE");
- return options;
+ return DiskCache::Disabled;
}
void ExecutionEngine::callInContext(QV4::Function *function, QObject *self,
--
2.42.0