me
/
guix
Archived
1
0
Fork 0
This repository has been archived on 2024-08-07. You can view files and clone it, but cannot push or open issues/pull-requests.
guix/gnu/packages/patches/emacs-helpful-fix-docstring...

19 lines
681 B
Diff

This patch fixing a build failure has been cherry-picked from upstream.
Originally submitted as pull request by Erik Šabič.
See also <https://github.com/Wilfred/helpful/pull/296>.
diff --git a/test/helpful-unit-test.el b/test/helpful-unit-test.el
index a07aa8e..8a95129 100644
--- a/test/helpful-unit-test.el
+++ b/test/helpful-unit-test.el
@@ -119,7 +119,9 @@ bar")))
(should
(equal
(helpful--docstring #'test-foo-advised t)
- "Docstring here too.")))
+ (if (version< emacs-version "28")
+ "Docstring here too."
+ "Docstring here too.\n\nThis function has :around advice: `ad-Advice-test-foo-advised'."))))
(defun test-foo-no-docstring ()
nil)