55 lines
1.8 KiB
Diff
55 lines
1.8 KiB
Diff
From 3e1f4da8c0e536c09ffaf3b43fe2eb5dc17cc23e Mon Sep 17 00:00:00 2001
|
|
From: Georges Basile Stavracas Neto <georges.stavracas@gmail.com>
|
|
Date: Thu, 18 Nov 2021 19:46:13 -0300
|
|
Subject: [PATCH] flatpak: Adjust to libportal changes
|
|
|
|
---
|
|
build-aux/flatpak/org.gnome.Todo.json | 3 +++
|
|
src/plugins/background/gtd-plugin-background.c | 2 +-
|
|
src/plugins/background/meson.build | 2 +-
|
|
3 files changed, 5 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/build-aux/flatpak/org.gnome.Todo.json b/build-aux/flatpak/org.gnome.Todo.json
|
|
index 034e200c..44b83d66 100644
|
|
--- a/build-aux/flatpak/org.gnome.Todo.json
|
|
+++ b/build-aux/flatpak/org.gnome.Todo.json
|
|
@@ -143,6 +143,9 @@
|
|
{
|
|
"name" : "libportal",
|
|
"buildsystem" : "meson",
|
|
+ "config-opts" : [
|
|
+ "-Dbackends=gtk4"
|
|
+ ],
|
|
"sources" : [
|
|
{
|
|
"type" : "git",
|
|
diff --git a/src/plugins/background/gtd-plugin-background.c b/src/plugins/background/gtd-plugin-background.c
|
|
index cf48786c..f64d07aa 100644
|
|
--- a/src/plugins/background/gtd-plugin-background.c
|
|
+++ b/src/plugins/background/gtd-plugin-background.c
|
|
@@ -28,7 +28,7 @@
|
|
#include <gtk/gtk.h>
|
|
|
|
#include <libportal/portal.h>
|
|
-#include <libportal/portal-gtk4.h>
|
|
+#include <libportal-gtk4/portal-gtk4.h>
|
|
|
|
#define AUTOSTART_NOTIFICATION_ID "Gtd::BackgroundPlugin::autostart_notification"
|
|
#define AUTOSTART_NOTIFICATION_TIMEOUT 3 /* seconds */
|
|
diff --git a/src/plugins/background/meson.build b/src/plugins/background/meson.build
|
|
index a671a4f3..59d3635f 100644
|
|
--- a/src/plugins/background/meson.build
|
|
+++ b/src/plugins/background/meson.build
|
|
@@ -1,7 +1,7 @@
|
|
plugins_ldflags += ['-Wl,--undefined=gtd_plugin_background_register_types']
|
|
|
|
plugins_deps += [
|
|
- dependency('libportal'),
|
|
+ dependency('libportal-gtk4'),
|
|
]
|
|
|
|
plugins_sources += files(
|
|
--
|
|
GitLab
|
|
|