52 lines
1.4 KiB
Diff
52 lines
1.4 KiB
Diff
Make some of the changes needed to the 'makeicecat' script, to allow it to run
|
|
in a snippet without network access. After this patch is applied, some
|
|
additional changes will be made using 'substitute*'.
|
|
|
|
diff --git a/makeicecat b/makeicecat
|
|
index bf2b7a6..bc3b19b 100755
|
|
--- a/makeicecat
|
|
+++ b/makeicecat
|
|
@@ -58,7 +58,7 @@ readonly SOURCEDIR=icecat-${FFVERSION}
|
|
# debug/shell options
|
|
readonly DEVEL=0
|
|
set -euo pipefail
|
|
-(( DEVEL )) && set -x
|
|
+set -x
|
|
|
|
|
|
###############################################################################
|
|
@@ -459,7 +459,7 @@ configure_search()
|
|
sed 's|ddg@|ddg-html@|' -i browser/components/search/extensions/ddg-html/manifest.json
|
|
|
|
# Process various JSON pre-configuration dumps.
|
|
- python3 ../../tools/process-json-files.py . browser/components/extensions/schemas/
|
|
+ python3 "${DATADIR}"/../tools/process-json-files.py . browser/components/extensions/schemas/
|
|
}
|
|
|
|
configure_mobile()
|
|
@@ -855,12 +855,12 @@ finalize_sourceball()
|
|
# entry point
|
|
###############################################################################
|
|
|
|
-validate_env || exit 1
|
|
-prepare_env
|
|
-fetch_source
|
|
-verify_sources
|
|
-extract_sources
|
|
-fetch_l10n
|
|
+# validate_env || exit 1
|
|
+# prepare_env
|
|
+# fetch_source
|
|
+# verify_sources
|
|
+# extract_sources
|
|
+# fetch_l10n
|
|
apply_patches
|
|
configure
|
|
configure_search
|
|
@@ -872,4 +872,4 @@ prepare_macos_packaging
|
|
configure_extensions
|
|
configure_onboarding
|
|
apply_bugfixes
|
|
-finalize_sourceball
|
|
+# finalize_sourceball
|