me
/
guix
Archived
1
0
Fork 0
This repository has been archived on 2024-08-07. You can view files and clone it, but cannot push or open issues/pull-requests.
guix/gnu/packages/patches/genimage-signedness.patch

25 lines
1.0 KiB
Diff
Raw Blame History

This file contains ambiguous Unicode characters!

This file contains ambiguous Unicode characters that may be confused with others in your current locale. If your use case is intentional and legitimate, you can safely ignore this warning. Use the Escape button to highlight these characters.

commit 6574665f9d6c0757e8f55ccb465afbcaa90bf019
Author: Timotej Lazar <timotej.lazar@araneo.si>
Date: Wed Aug 19 19:36:02 2020 +0200
test: normalize flags reported by dumpe2fs
Filesystem flags depend on the system usually signed_directory_hash,
but unsigned_directory_hash at least on arm64.
Signed-off-by: Timotej Lazar <timotej.lazar@araneo.si>
diff --git a/test/basic-images.test b/test/basic-images.test
index f6685e1..cb104c3 100755
--- a/test/basic-images.test
+++ b/test/basic-images.test
@@ -158,6 +158,8 @@ check_ext() {
# format change
csum2="Group 0: (Blocks 1-4095) \\[ITABLE_ZEROED\\]\| Checksum .*, unused inodes 205"
dumpe2fs "${1}" | grep -v "^\($uuid\|$seed\|$csum1\|$csum2\)" > "dump" &&
+ # some architectures (including arm64) use unsigned char
+ sed -i 's/un\(signed_directory_hash\)/\1/' "dump" &&
# fixup for ext3 journal size with old tune2fs
sed -i 's/^\(Journal size: \)1029k$/\11024k/' "dump" &&
# output format changed with some version