me
/
guix
Archived
1
0
Fork 0
This repository has been archived on 2024-08-07. You can view files and clone it, but cannot push or open issues/pull-requests.
guix/gnu/packages/patches/purescript-relax-dependenci...

41 lines
1.2 KiB
Diff

Allow the purescript dependencies to better match the available packages in
Guix.
--- purescript-0.13.8/purescript.cabal
+++ purescript-0.13.8/purescript.cabal.orig
@@ -1091 +1091 @@ library
- Glob ==0.9.*,
+ Glob ==0.10.*,
@@ -1095 +1095 @@ library
- ansi-terminal >=0.7.1 && <0.9,
+ ansi-terminal ==0.9.*,
@@ -1105 +1105 @@ library
- clock <0.8,
+ clock ==0.8.*,
@@ -1173 +1173 @@ executable purs
- Glob ==0.9.*,
+ Glob ==0.10.*,
@@ -1177 +1177 @@ executable purs
- ansi-terminal >=0.7.1 && <0.9,
+ ansi-terminal ==0.9.*,
@@ -1188 +1188 @@ executable purs
- clock <0.8,
+ clock ==0.8.*,
@@ -1209 +1209 @@ executable purs
- network >=3.0.1.1 && <3.1,
+ network >=2.8 && <3.1,
@@ -1288 +1288 @@ test-suite tests
- Glob ==0.9.*,
+ Glob ==0.10.*,
@@ -1293 +1293 @@ test-suite tests
- ansi-terminal >=0.7.1 && <0.9,
+ ansi-terminal ==0.9.*,
@@ -1303 +1303 @@ test-suite tests
- clock <0.8,
+ clock ==0.8.*,
@@ -1315,2 +1315,2 @@ test-suite tests
- hspec <2.7,
- hspec-discover <2.7,
+ hspec ==2.7.*,
+ hspec-discover ==2.7.*,