30 lines
1.1 KiB
Diff
30 lines
1.1 KiB
Diff
Do not build and install clinfo.
|
|
|
|
diff --git a/CMakeLists.txt.orig b/CMakeLists.txt
|
|
index 76847d3..3f62bfe 100644
|
|
--- a/CMakeLists.txt.orig
|
|
+++ b/CMakeLists.txt
|
|
@@ -15,9 +15,9 @@ option(FILE_REORG_BACKWARD_COMPATIBILITY "Enable File Reorganization backward co
|
|
|
|
|
|
set(OPENCL_ICD_LOADER_HEADERS_DIR "${CMAKE_CURRENT_LIST_DIR}/khronos/headers/opencl2.2" CACHE PATH "")
|
|
#add_subdirectory(khronos/icd)
|
|
add_subdirectory(amdocl)
|
|
-add_subdirectory(tools/clinfo)
|
|
+#add_subdirectory(tools/clinfo)
|
|
add_subdirectory(tools/cltrace)
|
|
if(BUILD_TESTS)
|
|
add_subdirectory(tests/ocltst)
|
|
diff --git a/packaging/CMakeLists.txt b/packaging/CMakeLists.txt
|
|
index 48353eb..cd1e7c1 100644
|
|
--- a/packaging/CMakeLists.txt
|
|
+++ b/packaging/CMakeLists.txt
|
|
@@ -5,6 +5,6 @@ set(CPACK_COMPONENTS_ALL binary dev icd)
|
|
set(CPACK_DEB_COMPONENT_INSTALL ON)
|
|
set(CPACK_RPM_COMPONENT_INSTALL ON)
|
|
|
|
-install(TARGETS clinfo DESTINATION bin COMPONENT binary)
|
|
+#install(TARGETS clinfo DESTINATION bin COMPONENT binary)
|
|
install(TARGETS amdocl DESTINATION lib COMPONENT binary)
|
|
install(FILES ${CMAKE_SOURCE_DIR}/LICENSE.txt DESTINATION share/doc/${CMAKE_PROJECT_NAME} COMPONENT binary)
|