17 lines
751 B
Diff
17 lines
751 B
Diff
Description: prevent relocating initrd & fdt, that results in failure to boot
|
|
Author: Heinrich Schuchardt (xypron)
|
|
Bug-Ubuntu: https://bugs.launchpad.net/ubuntu/+source/u-boot/+bug/1937246
|
|
Index: u-boot-2021.07~rc4+dfsg/include/configs/sifive-unmatched.h
|
|
===================================================================
|
|
--- u-boot-2021.07~rc4+dfsg.orig/include/configs/sifive-unmatched.h
|
|
+++ u-boot-2021.07~rc4+dfsg/include/configs/sifive-unmatched.h
|
|
@@ -55,6 +55,8 @@
|
|
"name=system,size=-,bootable,type=${type_guid_gpt_system};"
|
|
|
|
#define CFG_EXTRA_ENV_SETTINGS \
|
|
+ "fdt_high=0xffffffffffffffff\0" \
|
|
+ "initrd_high=0xffffffffffffffff\0" \
|
|
"kernel_addr_r=0x84000000\0" \
|
|
"kernel_comp_addr_r=0x88000000\0" \
|
|
"kernel_comp_size=0x4000000\0" \
|