56 lines
1.2 KiB
Diff
56 lines
1.2 KiB
Diff
Remove dependencies on xwin and zig. We're not offering cross-compilation
|
|
options using these crates.
|
|
|
|
diff --git a/Cargo.toml b/Cargo.toml
|
|
index 6704e46..ff126a9 100644
|
|
--- a/Cargo.toml
|
|
+++ b/Cargo.toml
|
|
@@ -83,16 +83,6 @@ version = "0.1.16"
|
|
[dependencies.cargo-options]
|
|
version = "0.7.2"
|
|
|
|
-[dependencies.cargo-xwin]
|
|
-version = "0.16.2"
|
|
-optional = true
|
|
-default-features = false
|
|
-
|
|
-[dependencies.cargo-zigbuild]
|
|
-version = "0.18.0"
|
|
-optional = true
|
|
-default-features = false
|
|
-
|
|
[dependencies.cargo_metadata]
|
|
version = "0.18.0"
|
|
|
|
@@ -321,8 +311,6 @@ version = "5.0.0"
|
|
[features]
|
|
cli-completion = ["dep:clap_complete_command"]
|
|
cross-compile = [
|
|
- "zig",
|
|
- "xwin",
|
|
]
|
|
default = [
|
|
"full",
|
|
@@ -341,7 +329,6 @@ log = ["tracing-subscriber"]
|
|
native-tls = [
|
|
"dep:native-tls",
|
|
"ureq?/native-tls",
|
|
- "cargo-xwin?/native-tls",
|
|
"dep:rustls-pemfile",
|
|
]
|
|
password-storage = [
|
|
@@ -351,7 +338,6 @@ password-storage = [
|
|
rustls = [
|
|
"dep:rustls",
|
|
"ureq?/tls",
|
|
- "cargo-xwin?/rustls-tls",
|
|
"dep:rustls-pemfile",
|
|
]
|
|
scaffolding = [
|
|
@@ -369,5 +355,3 @@ upload = [
|
|
"wild",
|
|
"dep:dirs",
|
|
]
|
|
-xwin = ["cargo-xwin"]
|
|
-zig = ["cargo-zigbuild"]
|