me
/
guix
Archived
1
0
Fork 0
This repository has been archived on 2024-08-07. You can view files and clone it, but cannot push or open issues/pull-requests.
guix/gnu/packages/patches/freecad-boost-serialization...

28 lines
827 B
Diff

Taken from: https://github.com/archlinux/svntogit-community/blob/packages/freecad/trunk/freecad-boost.patch.
Index: FreeCAD-0.19.2/CMakeLists.txt
===================================================================
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -46,6 +46,7 @@ if(NOT FREECAD_LIBPACK_USE OR FREECAD_LI
SetupPCL()
SetupPybind11()
SetupBoost()
+ set(Boost_LIBRARIES_App ${Boost_LIBRARIES})
SetupXercesC()
find_package(ZLIB REQUIRED)
find_package(PyCXX REQUIRED)
Index: FreeCAD-0.19.2/src/App/CMakeLists.txt
===================================================================
--- a/src/App/CMakeLists.txt
+++ b/src/App/CMakeLists.txt
@@ -59,7 +59,7 @@ include_directories(
set(FreeCADApp_LIBS
FreeCADBase
- ${Boost_LIBRARIES}
+ ${Boost_LIBRARIES_App}
)
if (BUILD_QT5)