me
/
guix
Archived
1
0
Fork 0
This repository has been archived on 2024-08-07. You can view files and clone it, but cannot push or open issues/pull-requests.
guix/gnu/packages/patches/hubbub-sort-entities.patch

14 lines
334 B
Diff

Traverse the entities hash's keys in sorted order to ensure reproducibility.
--- libhubbub-0.3.3/build/make-entities.pl
+++ libhubbub-0.3.3/build/make-entities.pl
@@ -86,7 +86,7 @@
my $trie;
-foreach my $key (keys %entities) {
+foreach my $key (sort keys %entities) {
$trie = insert_node($trie, $key, $entities{$key});
}