me
/
guix
Archived
1
0
Fork 0
This repository has been archived on 2024-08-07. You can view files and clone it, but cannot push or open issues/pull-requests.
guix/gnu/packages/patches/python-robotframework-sshli...

20 lines
607 B
Diff

This patches add compatibility for the forthcoming RobotFramework 5.
Taken from: https://github.com/robotframework/SSHLibrary/pull/403.
diff --git a/src/SSHLibrary/pythonforward.py b/src/SSHLibrary/pythonforward.py
index 8b85997b7..607985cf4 100644
--- a/src/SSHLibrary/pythonforward.py
+++ b/src/SSHLibrary/pythonforward.py
@@ -1,9 +1,9 @@
import select
import socket
import threading
-from robot.utils import platform
+from robot.utils import PY2, WINDOWS
from .logger import logger
-if platform.PY2 and platform.WINDOWS:
+if PY2 and WINDOWS:
import win_inet_pton
try:
import SocketServer