43 lines
1.1 KiB
Diff
43 lines
1.1 KiB
Diff
Make some of the changes needed to the 'makeicecat' script, to allow it to run
|
|
in a snippet without network access. After this patch is applied, some
|
|
additional changes will be made using 'substitute*'.
|
|
|
|
diff --git a/makeicecat b/makeicecat
|
|
index bf2b7a6..bc3b19b 100755
|
|
--- a/makeicecat
|
|
+++ b/makeicecat
|
|
@@ -56,7 +56,7 @@ readonly SOURCEDIR=icecat-${FFVERSION}
|
|
# debug/shell options
|
|
readonly DEVEL=0
|
|
set -euo pipefail
|
|
-(( DEVEL )) && set -x
|
|
+set -x
|
|
|
|
|
|
###############################################################################
|
|
@@ -928,12 +928,12 @@ finalize_sourceball()
|
|
# entry point
|
|
###############################################################################
|
|
|
|
-validate_env || exit 1
|
|
-prepare_env
|
|
-fetch_source
|
|
-verify_sources
|
|
-extract_sources
|
|
-fetch_l10n
|
|
+# validate_env || exit 1
|
|
+# prepare_env
|
|
+# fetch_source
|
|
+# verify_sources
|
|
+# extract_sources
|
|
+# fetch_l10n
|
|
apply_patches
|
|
configure
|
|
configure_search
|
|
@@ -945,4 +945,4 @@ prepare_macos_packaging
|
|
configure_extensions
|
|
configure_onboarding
|
|
apply_bugfixes
|
|
-finalize_sourceball
|
|
+# finalize_sourceball
|