Archived
1
0
Fork 0
This repository has been archived on 2024-08-07. You can view files and clone it, but cannot push or open issues or pull requests.
guix/gnu/packages/patches/binutils-mingw-w64-reproducible-import-libraries.patch
Carl Dong c1c50cb5b0
gnu: cross-base: Fix PACKAGE-WITH-EXTRA-PATCHES
This also removes the execute bit from the patches added. Not sure how
or why those were set in the first place.

* gnu/packages/cross-base.scm (package-with-extra-patches): Imitate
PACKAGE-WITH-PATCH instead of using it.
* gnu/packages/patches/binutils-mingw-w64-reproducible-import-libraries.patch:
Remove execute bit.
* gnu/packages/patches/binutils-mingw-w64-specify-timestamp.patch:
Remove execute bit.
2020-04-03 14:13:36 -04:00

22 lines
741 B
Diff

This following patch was originally found at the debian mingw-w64 team's
binutils repo located here:
https://salsa.debian.org/mingw-w64-team/binutils-mingw-w64.git
Invoke the following in the aforementioned repo to see the original patch:
$ git show da63f6b:debian/patches/reproducible-import-libraries.patch
Description: Make DLL import libraries reproducible
Author: Benjamin Moody <benjamin.moody@gmail.com>
Bug-Debian: https://bugs.debian.org/915055
--- a/ld/pe-dll.c
+++ b/ld/pe-dll.c
@@ -2844,6 +2844,7 @@
bfd_set_format (outarch, bfd_archive);
outarch->has_armap = 1;
+ outarch->flags |= BFD_DETERMINISTIC_OUTPUT;
/* Work out a reasonable size of things to put onto one line. */
ar_head = make_head (outarch);