me
/
guix
Archived
1
0
Fork 0
This repository has been archived on 2024-08-07. You can view files and clone it, but cannot push or open issues/pull-requests.
guix/gnu/packages/patches/thefuck-test-environ.patch

15 lines
490 B
Diff

Retain environment setting of "HOME" for tests that need os.path.expanduser()
to return a readable directory in the build chroot.
--- thefuck-3.25/tests/conftest.py
+++ thefuck-3.25/tests/conftest.py
@@ -64,6 +64,7 @@ def set_shell(monkeypatch):
@pytest.fixture(autouse=True)
def os_environ(monkeypatch):
- env = {'PATH': os.environ['PATH']}
+ env = {'PATH': os.environ['PATH'],
+ 'HOME': os.environ['HOME']}
monkeypatch.setattr('os.environ', env)
return env