me
/
guix
Archived
1
0
Fork 0
This repository has been archived on 2024-08-07. You can view files and clone it, but cannot push or open issues/pull-requests.
guix/gnu/packages/patches/emacs-telega-path-placehold...

39 lines
1.2 KiB
Diff

From bfcd616f2870c8c3ffc9a526fcd574eb5e726a96 Mon Sep 17 00:00:00 2001
From: Andrew Tropin <andrew@trop.in>
Date: Sat, 14 Jan 2023 09:33:34 +0400
Subject: [PATCH] Add path placeholder for telega-server-command and etc-file.
---
telega-core.el | 2 +-
telega-customize.el | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/telega-core.el b/telega-core.el
index 36f121e..f9f7976 100644
--- a/telega-core.el
+++ b/telega-core.el
@@ -41,7 +41,7 @@
(defun telega-etc-file (filename)
"Return absolute path to FILENAME from etc/ directory in telega."
- (expand-file-name (concat "etc/" filename) telega--lib-directory))
+ (concat "@TELEGA_SHARE@" "/" filename))
(defconst telega-spoiler-translation-table
(let ((table (make-char-table 'translation-table)))
diff --git a/telega-customize.el b/telega-customize.el
index 0efb001..77cec5f 100644
--- a/telega-customize.el
+++ b/telega-customize.el
@@ -633,7 +633,7 @@ In range [1..3]. Use 1."
:prefix "telega-server-"
:group 'telega)
-(defcustom telega-server-command "telega-server"
+(defcustom telega-server-command "@TELEGA_SERVER_BIN@"
"Command to run as telega server.
It should be absolute path or binary file searchable in `exec-path'."
:type 'string
--
2.38.1