29 lines
1.2 KiB
Diff
29 lines
1.2 KiB
Diff
From f75c1613db67f4067643d0218a2db3235e42ec9f Mon Sep 17 00:00:00 2001
|
|
From: Jean Ghali <jghali@libertysurf.fr>
|
|
Date: Thu, 3 Feb 2022 19:46:13 +0000
|
|
Subject: [PATCH] Small update vs latest code in poppler
|
|
|
|
git-svn-id: svn://scribus.net/trunk/Scribus@24885 11d20701-8431-0410-a711-e3c959e3b870
|
|
---
|
|
scribus/plugins/import/pdf/slaoutput.cpp | 6 +++---
|
|
1 file changed, 3 insertions(+), 3 deletions(-)
|
|
|
|
diff --git a/scribus/plugins/import/pdf/slaoutput.cpp b/scribus/plugins/import/pdf/slaoutput.cpp
|
|
index 3650c96f52..a6f4e00fa9 100644
|
|
--- a/scribus/plugins/import/pdf/slaoutput.cpp
|
|
+++ b/scribus/plugins/import/pdf/slaoutput.cpp
|
|
@@ -3072,10 +3072,10 @@ void SlaOutputDev::updateFont(GfxState *state)
|
|
delete id;
|
|
else
|
|
{
|
|
- if (!(fontLoc = gfxFont->locateFont(xref, nullptr)))
|
|
+ fontLoc = gfxFont->locateFont((xref) ? xref : pdfDoc->getXRef(), nullptr);
|
|
+ if (!fontLoc)
|
|
{
|
|
- error(errSyntaxError, -1, "Couldn't find a font for '{0:s}'",
|
|
- gfxFont->getName() ? gfxFont->getName()->getCString() : "(unnamed)");
|
|
+ error(errSyntaxError, -1, "Couldn't find a font for '{0:s}'", gfxFont->getName() ? gfxFont->getName()->getCString() : "(unnamed)");
|
|
goto err2;
|
|
}
|
|
|