* gnu/packages/gnome.scm (nautilus): Update to 42.2. [patches]: Replace nautilus-add-libportal-gtk3.patch with nautilus-disable-tracker-tests.patch. [tests?]: Delete argument. [phases]: Use gexps. {check}: Move after install. {pre-check}: New phase. [native-inputs]: Replace intltool with gettext-minimal. Add python-pygobject. [inputs]: Remove libsoup-minimal-2. * gnu/packages/patches/nautilus-add-libportal-gtk3.patch: Delete file. * gnu/packages/patches/nautilus-disable-tracker-tests.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly.
47 lines
1.4 KiB
Diff
47 lines
1.4 KiB
Diff
The tracker test hangs in the build container (see:
|
|
https://gitlab.gnome.org/GNOME/nautilus/-/issues/2486).
|
|
|
|
--- a/test/automated/displayless/meson.build 2022-09-10 00:52:50.348405729 -0400
|
|
+++ b/test/automated/displayless/meson.build 2022-09-10 00:53:07.267907525 -0400
|
|
@@ -34,41 +34,3 @@
|
|
'test-file-operations-trash-or-delete.c'
|
|
]]
|
|
]
|
|
-
|
|
-tracker_tests = [
|
|
- ['test-nautilus-search-engine-tracker', [
|
|
- 'test-nautilus-search-engine-tracker.c',
|
|
- ]],
|
|
-]
|
|
-
|
|
-foreach t: tests
|
|
- test(
|
|
- t[0],
|
|
- executable(t[0], t[1], files('test-utilities.c'), dependencies: libnautilus_dep),
|
|
- env: [
|
|
- test_env,
|
|
- 'G_TEST_BUILDDIR=@0@'.format(meson.current_build_dir()),
|
|
- 'G_TEST_SRCDIR=@0@'.format(meson.current_source_dir())
|
|
- ],
|
|
- timeout: 480
|
|
- )
|
|
-endforeach
|
|
-
|
|
-
|
|
-
|
|
-# Tests that read and write from the Tracker index are run using 'tracker-sandbox'
|
|
-# script to use a temporary instance of tracker-miner-fs instead of the session one.
|
|
-foreach t: tracker_tests
|
|
- test_exe = executable(t[0], t[1], files('test-utilities.c'), dependencies: libnautilus_dep)
|
|
- test(
|
|
- t[0],
|
|
- tracker_sandbox,
|
|
- args: ['--store-tmpdir', '--index-recursive-tmpdir', test_exe],
|
|
- env: [
|
|
- test_env,
|
|
- 'G_TEST_BUILDDIR=@0@'.format(meson.current_build_dir()),
|
|
- 'G_TEST_SRCDIR=@0@'.format(meson.current_source_dir())
|
|
- ],
|
|
- timeout: 480
|
|
- )
|
|
-endforeach
|