me
/
guix
Archived
1
0
Fork 0
This repository has been archived on 2024-08-07. You can view files and clone it, but cannot push or open issues/pull-requests.
guix/gnu/packages/patches/mesa-skip-tests.patch

30 lines
861 B
Diff

This test fails on i686-linux. I couldn't come up with a regex that
could be used to disable it just on i686-linux, so we disable it
completely with this patch:
https://gitlab.freedesktop.org/mesa/mesa/-/issues/4091
diff --git a/src/util/meson.build b/src/util/meson.build
index 0893f64..909b3e0 100644
--- a/src/util/meson.build
+++ b/src/util/meson.build
@@ -289,18 +289,6 @@ if with_tests
suite : ['util'],
)
- test(
- 'u_debug_stack',
- executable(
- 'u_debug_stack_test',
- files('u_debug_stack_test.cpp'),
- include_directories : [inc_include, inc_src, inc_mapi, inc_mesa, inc_gallium, inc_gallium_aux],
- dependencies : [idep_mesautil, idep_gtest],
- c_args : [c_msvc_compat_args],
- ),
- suite : ['util'],
- )
-
process_test_exe = executable(
'process_test',
files('process_test.c'),