76 lines
2.9 KiB
Diff
76 lines
2.9 KiB
Diff
From faa95a784d2c74c72e70367a5d531df6dd61aeab Mon Sep 17 00:00:00 2001
|
|
From: Steve Purcell <steve@sanityinc.com>
|
|
Date: Sun, 6 Aug 2023 16:41:48 +0200
|
|
Subject: [PATCH] Don't redefine built-in function
|
|
|
|
Fixes #1817
|
|
---
|
|
tests/haskell-indent-tests.el | 14 ++++++++------
|
|
tests/haskell-indentation-tests.el | 14 ++++++++------
|
|
2 files changed, 16 insertions(+), 12 deletions(-)
|
|
|
|
diff --git a/tests/haskell-indent-tests.el b/tests/haskell-indent-tests.el
|
|
index 7196405b8..9a3de4ad3 100644
|
|
--- a/tests/haskell-indent-tests.el
|
|
+++ b/tests/haskell-indent-tests.el
|
|
@@ -40,11 +40,13 @@
|
|
;; (haskell-indent-put-region-in-literate (point-min) (point-max) -1)
|
|
;; (buffer-substring-no-properties (point-min) (point-max))))))
|
|
|
|
-(defsubst string-trim-left (string)
|
|
- "Remove leading whitespace from STRING."
|
|
- (if (string-match "\\`[ \t\n\r]+" string)
|
|
- (replace-match "" t t string)
|
|
- string))
|
|
+(if (fboundp 'string-trim-left)
|
|
+ (defalias 'haskell--string-trim-left 'string-trim-left)
|
|
+ (defun haskell--string-trim-left (string &optional regexp)
|
|
+ "Remove leading whitespace from STRING."
|
|
+ (if (string-match (concat "\\`\\(?:" (or regexp "[ \t\n\r]+") "\\)") string)
|
|
+ (substring string (match-end 0))
|
|
+ string)))
|
|
|
|
(defun haskell-indent-format-info (info)
|
|
(if (cdr info)
|
|
@@ -128,7 +130,7 @@ macro quotes them for you."
|
|
:expected-result
|
|
,(if allow-failure :failed :passed)
|
|
(haskell-indent-check
|
|
- ,(string-trim-left source)
|
|
+ ,(haskell--string-trim-left source)
|
|
,@(mapcar (lambda (x)
|
|
(list 'quote x))
|
|
test-cases))))))
|
|
diff --git a/tests/haskell-indentation-tests.el b/tests/haskell-indentation-tests.el
|
|
index 4889b76a7..cd783a4f4 100644
|
|
--- a/tests/haskell-indentation-tests.el
|
|
+++ b/tests/haskell-indentation-tests.el
|
|
@@ -33,11 +33,13 @@
|
|
|
|
;;; Code:
|
|
|
|
-(defsubst string-trim-left (string)
|
|
- "Remove leading whitespace from STRING."
|
|
- (if (string-match "\\`[ \t\n\r]+" string)
|
|
- (replace-match "" t t string)
|
|
- string))
|
|
+(if (fboundp 'string-trim-left)
|
|
+ (defalias 'haskell--string-trim-left 'string-trim-left)
|
|
+ (defun haskell--string-trim-left (string &optional regexp)
|
|
+ "Remove leading whitespace from STRING."
|
|
+ (if (string-match (concat "\\`\\(?:" (or regexp "[ \t\n\r]+") "\\)") string)
|
|
+ (substring string (match-end 0))
|
|
+ string)))
|
|
|
|
(defun haskell-indentation-check (source &rest test-cases)
|
|
"Check if `haskell-indentation-find-indentations' returns expected results.
|
|
@@ -115,7 +117,7 @@ macro quotes them for you."
|
|
:expected-result
|
|
,(if allow-failure :failed :passed)
|
|
(haskell-indentation-check
|
|
- ,(string-trim-left source)
|
|
+ ,(haskell--string-trim-left source)
|
|
,@(mapcar (lambda (x)
|
|
(list 'quote x))
|
|
test-cases))))))
|