me
/
guix
Archived
1
0
Fork 0
This repository has been archived on 2024-08-07. You can view files and clone it, but cannot push or open issues/pull-requests.
guix/gnu/packages/patches/python-pyreadstat-link-libi...

16 lines
384 B
Diff

To ensure libiconv can be found by Guix, we need to link the library.
--- a/setup.py
+++ b/setup.py
@@ -81,8 +81,7 @@ else:
libraries.extend(["m", "z"])
_platform = sys.platform
# Mac: iconv needs to be linked statically
- if _platform.lower().startswith("darwin"):
- libraries.append("iconv")
+ libraries.append("iconv")
# Extensions
sources.sort()