me
/
guix
Archived
1
0
Fork 0
This repository has been archived on 2024-08-07. You can view files and clone it, but cannot push or open issues/pull-requests.
guix/gnu/packages/patches/libaio-32bit-test.patch

27 lines
626 B
Diff

This fix comes from an upstream pull request, see
https://pagure.io/libaio/pull-request/22#commit_list
diff --git a/harness/cases/23.t b/harness/cases/23.t
index cc5a8a1..9bbb05c 100644
--- a/harness/cases/23.t
+++ b/harness/cases/23.t
@@ -72,7 +72,7 @@ static void fail_errno(const char *format, ...)
static void *thrproc2(void *arg)
{
for (;;) {
- off_t offset = 0;
+ off64_t offset = 0;
pthread_barrier_wait(&barrier);
if (exiting)
@@ -92,7 +92,7 @@ static void *thrproc3(void *arg)
{
for (;;) {
char c;
- off_t offset = 0;
+ off64_t offset = 0;
pthread_barrier_wait(&barrier);
if (exiting)