me
/
guix
Archived
1
0
Fork 0
This repository has been archived on 2024-08-07. You can view files and clone it, but cannot push or open issues/pull-requests.
guix/gnu/packages/patches/pdfpc-build-with-vala-0.56....

41 lines
1.5 KiB
Diff

From 18beaecbbcc066e0d4c889b3aa3ecaa7351f7768 Mon Sep 17 00:00:00 2001
Message-ID: <18beaecbbcc066e0d4c889b3aa3ecaa7351f7768.1711183363.git.vivien@planete-kraus.eu>
From: Evgeny Stambulchik <fnevgeny@gmail.com>
Date: Tue, 25 Apr 2023 16:11:25 +0300
Subject: [PATCH] Create Lists of nullable types
---
This is the pull request for issue 686, merged in master, not released
yet.
src/classes/drawings/drawing_commands.vala | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/src/classes/drawings/drawing_commands.vala b/src/classes/drawings/drawing_commands.vala
index 77e56e6..c305a8c 100644
--- a/src/classes/drawings/drawing_commands.vala
+++ b/src/classes/drawings/drawing_commands.vala
@@ -54,8 +54,8 @@ namespace pdfpc {
}
public void clear() {
- this.drawing_commands = new List<DrawingCommand>();
- this.redo_commands = new List<DrawingCommand>();
+ this.drawing_commands = new List<DrawingCommand?>();
+ this.redo_commands = new List<DrawingCommand?>();
}
public void add_line(bool is_eraser,
@@ -70,7 +70,7 @@ namespace pdfpc {
// After adding a new line you can no longer redo the old
// path.
- this.redo_commands = new List<DrawingCommand>(); // clear
+ this.redo_commands = new List<DrawingCommand?>(); // clear
bool new_path = true;
double epsilon = 1e-4; // Less than 0.1 pixel for a 1000x1000 img
--
2.41.0