gnu: Add vcmi.
* gnu/packages/games.scm (vcmi): New variable. * gnu/packages/patches/vcmi-disable-privacy-breach.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it here. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
parent
4c610d2b2e
commit
8306d3e529
|
@ -2053,6 +2053,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/vboot-utils-fix-format-load-address.patch \
|
%D%/packages/patches/vboot-utils-fix-format-load-address.patch \
|
||||||
%D%/packages/patches/vboot-utils-fix-tests-show-contents.patch \
|
%D%/packages/patches/vboot-utils-fix-tests-show-contents.patch \
|
||||||
%D%/packages/patches/vboot-utils-skip-test-workbuf.patch \
|
%D%/packages/patches/vboot-utils-skip-test-workbuf.patch \
|
||||||
|
%D%/packages/patches/vcmi-disable-privacy-breach.patch \
|
||||||
%D%/packages/patches/vinagre-newer-freerdp.patch \
|
%D%/packages/patches/vinagre-newer-freerdp.patch \
|
||||||
%D%/packages/patches/vinagre-newer-rdp-parameters.patch \
|
%D%/packages/patches/vinagre-newer-rdp-parameters.patch \
|
||||||
%D%/packages/patches/virtuoso-ose-remove-pre-built-jar-files.patch \
|
%D%/packages/patches/virtuoso-ose-remove-pre-built-jar-files.patch \
|
||||||
|
|
|
@ -203,6 +203,7 @@
|
||||||
#:use-module (gnu packages sqlite)
|
#:use-module (gnu packages sqlite)
|
||||||
#:use-module (gnu packages squirrel)
|
#:use-module (gnu packages squirrel)
|
||||||
#:use-module (gnu packages swig)
|
#:use-module (gnu packages swig)
|
||||||
|
#:use-module (gnu packages tbb)
|
||||||
#:use-module (gnu packages tcl)
|
#:use-module (gnu packages tcl)
|
||||||
#:use-module (gnu packages terminals)
|
#:use-module (gnu packages terminals)
|
||||||
#:use-module (gnu packages texinfo)
|
#:use-module (gnu packages texinfo)
|
||||||
|
@ -11307,6 +11308,54 @@ Magic II (aka HOMM2) game engine. It requires assets and game resources to
|
||||||
play; it will look for them at @file{~/.local/share/fheroes2} folder.")
|
play; it will look for them at @file{~/.local/share/fheroes2} folder.")
|
||||||
(license license:gpl2)))
|
(license license:gpl2)))
|
||||||
|
|
||||||
|
(define-public vcmi
|
||||||
|
(package
|
||||||
|
(name "vcmi")
|
||||||
|
(version "1.2.1")
|
||||||
|
(source (origin
|
||||||
|
(method git-fetch)
|
||||||
|
(uri (git-reference
|
||||||
|
(url "https://github.com/vcmi/vcmi")
|
||||||
|
(commit version)))
|
||||||
|
(file-name (git-file-name name version))
|
||||||
|
(sha256
|
||||||
|
(base32
|
||||||
|
"0f3fk1fc2wb7f2j4pxz89dzr8zjnrdh435mijia483a3bq59w7pk"))
|
||||||
|
(patches (search-patches "vcmi-disable-privacy-breach.patch"))))
|
||||||
|
(build-system cmake-build-system)
|
||||||
|
(arguments
|
||||||
|
(list #:configure-flags #~(list "-DFORCE_BUNDLED_FL=OFF")
|
||||||
|
;; Test suites do not seem well supported upstream and are disabled by default.
|
||||||
|
;; Pass -DENABLE_TEST to configure to enable.
|
||||||
|
#:tests? #f))
|
||||||
|
(native-inputs
|
||||||
|
(list boost
|
||||||
|
ffmpeg
|
||||||
|
fuzzylite
|
||||||
|
;; googletest ; needed for tests, but tests are disabled
|
||||||
|
libxkbcommon
|
||||||
|
luajit
|
||||||
|
minizip
|
||||||
|
pkg-config
|
||||||
|
python
|
||||||
|
;; XXX: Build currently fails with qtbase-6 and qttools-6
|
||||||
|
qtbase-5
|
||||||
|
qttools-5
|
||||||
|
sdl2
|
||||||
|
sdl2-mixer
|
||||||
|
sdl2-image
|
||||||
|
sdl2-ttf
|
||||||
|
tbb
|
||||||
|
vulkan-headers
|
||||||
|
zlib))
|
||||||
|
(home-page "https://vcmi.eu/")
|
||||||
|
(synopsis "Turn-based strategy game engine")
|
||||||
|
(description
|
||||||
|
"@code{vcmi} is an implementation of the Heroes of Might and
|
||||||
|
Magic III game engine. It requires assets and game resources to
|
||||||
|
play; it will look for them at @file{~/.local/share/vcmi} folder.")
|
||||||
|
(license license:gpl2)))
|
||||||
|
|
||||||
(define-public apricots
|
(define-public apricots
|
||||||
(package
|
(package
|
||||||
(name "apricots")
|
(name "apricots")
|
||||||
|
|
|
@ -0,0 +1,21 @@
|
||||||
|
Origin: https://salsa.debian.org/games-team/vcmi/-/blob/debian/1.1.0+dfsg-1/debian/patches/disable-privacy-breach
|
||||||
|
From: Johannes Schauer <josch@debian.org>
|
||||||
|
Subject: do not check remote repositories on startup by default
|
||||||
|
Forwarded: not-needed
|
||||||
|
|
||||||
|
--- a/config/schemas/settings.json
|
||||||
|
+++ b/config/schemas/settings.json
|
||||||
|
@@ -401,11 +401,11 @@
|
||||||
|
},
|
||||||
|
"autoCheckRepositories" : {
|
||||||
|
"type" : "boolean",
|
||||||
|
- "default" : true
|
||||||
|
+ "default" : false
|
||||||
|
},
|
||||||
|
"updateOnStartup" : {
|
||||||
|
"type" : "boolean",
|
||||||
|
- "default" : true
|
||||||
|
+ "default" : false
|
||||||
|
},
|
||||||
|
"updateConfigUrl" : {
|
||||||
|
"type" : "string",
|
Reference in New Issue